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The Load Box User Interface System 

Introduction 

  
Introduction The Load Box User Interface System, LUIS, is an engine simulator used to 

facilitate bench top engine control system hardware and software testing. The 

second generation LUIS system, LUIS Gen2, provides expanded capabilities 

from the original LUIS. 

   
LUIS Physical 

Description 
The LUIS is a bench top, PC controlled customizable load box. A standard 

LUIS Gen2 system configuration contains: 

 

 Main Module 

 Wavemaker Module 

 2 Analog Modules 

 Switch Module 

 Resistive Loads Module 

 Injector and Application Specific Loads Module 

 

In addition, the user can request additional modules of each type depending 

on what is needed for their application. New modules are constantly being 

developed along with the ability to create custom modules for specific 

applications. Check with the GarTech engineering staff for additional 

information. 

 

This is a picture of a standard LUIS Gen2 system configuration. 

 

 

Continued on next page 
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Introduction, Continued 

 
LUIS Features The LUIIS Gen2 provides the following features. 

 

 Open and closed loop engine speed simulation 

 WaveMaker waveform generator, 8 channel arbitrary and 10 channel 

digital frequency outputs 

 LUIS Gen2 PC application allowing user complete control over I/O 

setup 

 Creation of configuration files to set up I/O for specific tests 

 Up to 128 16 bit DAC outputs 

 Up to 80 switch outputs 

 (1) 30A relay output 

 (4) 15A VBATT switched relay outputs 

 Up to 72 resistive load inputs 

 J1939 message simulation 

 Upgradable firmware 

Continued on next page 
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Chapter 1 – Installation and Setup 

Overview 

  
LUIS 

Hardware 
The LUIS Gen2 has a main module that is connected to the PC via USB. 

Additional modules can be added including Wavemaker, Switch, Analog and 

Resistive Loads to customize the system to fit the user’s specific needs. 

 
LUIS Gen2 

Software 
The LUIS Gen2 comes with a graphical user interface for controlling all 

outputs as well as for setting up closed loop controls and J1939 simulation. 

 
In This Section This table outlines the topics covered in this section. 

 

Topic See Page 

Software   4 

Hardware 6 
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Section 1 – Software 

Software 

 
Introduction The LUIS Gen2 has a graphical user interface that runs in the Windows 

environment. The LUIS GUI is made up of a tab system with a toolbar 

specific to each tab. 

 
LUIS GUI 

Basic 

Environment 

This diagram and table describe the basic LUIS Gen2 GUI environment. 

 

 

 
 

 Description 

1 Main Menu and Quick Access Toolbar 

2 Tabs – Options change based on the tab selected 

3 Workspace – All windows display in this space.  

Continued on next page 
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Software, Continued 

 
Windows Activities within the LUIS Gen2 environment occur in windows which 

display in the workspace. Like any Windows 7 application, windows can be 

closed by clicking the X in the right-hand corner. By default, the Startup 

window displays when LUIS is started. This includes a list of recently used 

configurations, new help topics, news and the Gartech website. The LUIS 

software can be configured to not show the Startup Window by clicking the 

Defaults menu option on the Home tab and changing the No Startup Page 

option. 

 
Downloading 

and Installing 

Drivers 

Before the LUIS Gen2 hardware and software can be installed, the driver 

must be downloaded and installed. Go to www.gartechenterprises.com and 

visit the download center to download and then follow the on-screen steps to 

install. 

 
Downloading 

and Installing 

Software 

To install the LUIS Gen2 graphical user interface, visit the 

www.gartechenterprises.com download center and download the software. 

Follow the on-screen instructions to install the software. 
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Section 2 – Hardware 

Overview 

 
Introduction LUIS Gen2 provides the ability to run a standard hardware configuration or 

add additional modules as needed.  

 
In This Section This table outlines the topics covered in this section. 

 

Topic See Page 

Ordering Hardware 7 

Setting Up a Standard LUIS Gen2 8 

Updating Devices 12 

 



Page 7 

 

Ordering Hardware 

 
Gartech 

Contact 

Information 

All hardware can be ordered from GarTech Enterprises, Inc. 
 

Gartech Enterprises, Inc. 

3037 W. State Road 256 

Austin, IN 47102 

812-794-4796 

www.gartechenterprises.com 

info@gartechenterprises.com 

  
GarTech Part 

Numbers 
This table lists the part number and descriptions for the LUIS hardware. 

 

Part Number Description 

G01641-00 LUIS Gen2 Assembly: 

(1) Main Module 

(1) WavemakerIII Module 

(2) Analog Modules 

(1) Switch Module 

(1) Resistive Loads Module 

(1) Injector Loads Module 

G01800-00 Main Module and Wavemaker III Module 

G01801-00 Analog Module 

G01802-00 Switch Module 

G01803-00 Resistive Loads Module 

  
GarTech 

Wiring 

Harnesses 

The user can specify how they would like to connect the I/O from the LUIS 

hardware to the target application and a custom harness can be designed. 

  

http://www.gartechenterprises/
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Setting Up a Standard LUIS Gen2 

 
Introduction The setup for a standard LUIS Gen 2 box is simple, requiring no special tools. 

Any ECM can be mounted to the top of the unit by moving the screw-in 

mounting pegs. It is then connected through a simple color-coded system. The 

unit communicates with the PC through a standard USB connection. 

  
Hardware 

Needed 
To set up the LUIS Gen2, the following hardware is required. 

 

 Standard LUIS 

 PC 

 Electronic Control Module 

 Wiring Harness 

 DC Power Cable 

 DC Power Supply 

 AC Power Cable 

 USB Cable 

 Loads Module Cable 

 Communications Cable 

 
Setting Up the 

Hardware 
This table outlines the physical connections required to set up the hardware to 

run a standard LUIS Gen2. 

 

Step Action 

1 Unscrew and configure the ECM pegs on top of the box, shown in 

Figure 1, to accommodate the ECM and mount the ECM on the 

pegs. 

2 Using the appropriate Wiring Harness, connect the Control 

Module to the LUIS Gen2 using the color coded ports on the back 

of the LUIS Gen2 box. 

4 Connect the 8 pin Unswitched Power Out connector port on the 

back of the LUIS Main Module 

5 Using the DC Power Cable, connect the LUIS Gen2 to the DC 

Power Supply using the Vbatt In port on the back of the LUIS 

Gen2, shown in Figure 2. 

Note: The DC Power Cable has a locking tab that must be 

depressed when disconnecting. 

Continued on next page 



Page 9 

 

Setting Up a Standard LUIS Gen2, Continued 

  
Figure 1: 

Mounting the 

ECM 

This image illustrates the mounting pegs on the top of the LUIS Gen2. 

 

 

   
Figure 2: 

DC Power 

Connections 

This picture illustrates the DC Power connection between the LUIS and the 

DC power supply. 

 

 

Continued on next page 
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Setting Up a Standard LUIS Gen2, Continued 

    
Setting Up the 

Hardware, 

Continued 

This table continues to outline the physical connections required to setup the 

hardware to run a standard LUIS Gen2. 

 

Step Action 

6 Using the Loads Module Cable, connect the Main Module to the 

Injector Specific Loads Module. 

Note: The cable is labeled Main Module End and Load Module 

End because it can be plugged in backwards. 

6 Using the AC Power Cable, show in Figure 3, plug the LUIS in. 

7 To complete the connection to the PC, plug a standard USB cable 

into the L-comm port on the back of the LUIS Gen2 and into a 

USB port on the PC. 

Continued on next page 
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Setting Up a Standard LUIS Gen2, Continued 

 
Figure 3:  

AC Power 

Supply 

This picture illustrates the AC power connection. 
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Updating Devices 

  
Introduction Gartech may periodically issue firmware upgrades for the modules. When 

upgrades are made available via the Gartech website, the user must download 

the file to the PC before downloading to the hardware. 

  
Updating 

Firmware 
This table outlines the steps for updating firmware. 

 

Step Action 

1 Download the appropriate firmware file from the Gartech website 

to the local PC. 

2 Ensure the LUIS Gen2 box is connected to the PC and running. 

3 From the LUIS Gen2 software Home tab, click the Devices icon. 

Result: The Devices window, shown in Figure 4, displays and the 

servers display in the Servers field. 

4 In the Servers field, select the correct server. 

Result: The devices available on that server display. 

5 In the Servers field, select the correct device. 

Result: The information for the device fills in on the right-hand 

side. 

6 Click the <Select File> button. 

Result: The Firmware File dialog box opens where the user can 

browse and select the file downloaded in Step 1. Once the file is 

selected and the user clicks <OK>, the dialog box closes and the 

name displays in the Firmware File field. 

7 Once the file has been selected and displays in the Firmware File 

field, click the <Download> button. 

Result: The status LED on the LUIS hardware will flash during the 

transfer then go out briefly while the hardware resets. A successful 

update results in the status LED turning back on. 

Continued on next page 
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Updating Devices, Continued 

  
Figure 4: 

Devices 

Window 

This graphic is an example of the Devices window. 
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Notes 
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Chapter 2 – Navigating the LUIS Gen2 GUI 

Overview 

  
Introduction The LUIS Gen2 graphical user interface provides a Windows based interface 

for communicating with the LUIS Gen2 box. The GUI is broken into 4 main 

tabs. All interaction takes place within windows in the workspace below these 

tabs. 

 
Main Menu The Main menu is accessed by clicking the LUIS icon on the upper left-hand 

portion of the window. This menu provides the ability to create a new 

configuration file or open/save an existing file. It also provides a list of 

recently opened configuration files and an interface to print the details of a 

configuration file. 

 
Quick Access 

Toolbar 
The Quick Access Toolbar displays, by default, above the tabs. This feature 

provides quick shortcuts for saving a configuration as well as adding or 

modifying a window. This toolbar can be moved to display below the main 

toolbar by clicking the down-arrow and selecting Show Below the Ribbon. 

 
Tabs The tabs within the GUI are described below.  

 

Tab Description 

Home Provides the interface for working with 

configurations, interacting with hardware, 

managing tables and plug-ins, working with the 

WaveMaker application and setting defaults 

Tools Provides the interface for creating windows and 

building configurations 

View Provides an interface for navigating between open 

windows 

Help Provides on-line help 

Continued on next page 
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Updating Devices, Continued 

 
Hiding the 

Tabs 
At any time the tabs can be hidden to provide more space in the workspace. 

Right-click on any empty spot on a tab and select the Minimize the Ribbon 

option. The tab ribbon is hidden and the tab names display across a narrow 

bar. Clicking on these names opens the tab and clicking again closes it. To 

maximize the tabs, right-click on the narrow bar where the tab names appear 

and deselect the Minimize the Ribbon option. The ribbon can also be 

minimized/maximized from the drop-down arrow on the Quick Access 

Toolbar. 

 
In This 

Chapter 
This table outlines the topics covered in this chapter. 

 

 

Topic See Page 

The Home Tab 17 

The Tools Tab 23 

The View and Help Tabs 60 

Printing a Configuration File Summary 61 
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Section 1 – The Home Tab 

The Home Tab 

 
Introduction The Home tab is the tab that displays when the LUIS Gen2 software is 

opened. This tab provides the ability to update hardware, open the 

WaveMaker configuration, manipulate configuration files, set defaults as well 

as manage plug-ins and tables. 

 
Home Tab 

Toolbar 
This image shows the Home tab toolbar. 

 

 

 
Hardware The Hardware section of the Home tab toolbar provides the ability to do 

some basic updating to the hardware.  

 

Icon Description 

 

Opens the Server Management window where servers 

can be added and edited. 

 

For more information about servers, see Page 128. 

 

Opens the Devices window where the devices can be 

selected and new firmware can be downloaded. 

 

For more information about downloading firmware, see 

Page 12. 

Continued on next page 
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The Home Tab, Continued 

 
Hardware, 

Continued 
This table continues to outline the capabilities available from the Hardware 

section of the Home tab toolbar. 

 

Icon Description 

 

Sets the value of all the controls in the current 

configuration to their default 

 
Plug-Ins, 

Tables, 

Wavemaker 

and Datalink 

Simulation 

The Plug-Ins, Tables, WaveMaker and Datalink Simulation sections of the 

Home tab toolbar provide the ability to manage plug-ins, tables and 

waveforms as well as simulate datalink messages. 

 

Icon Description 

 

View currently installed plugins 

 

Opens the Table Management window where 

interpolation tables can be defined. 

 

For more information about working with 

interpolation tables, see Page 65. 

 

Opens the WaveMaker Management window 

where waveforms can be defined for use with the 

WaveMaker application. 

 

For more information about the WaveMaker 

application see Page 78. 

Continued on next page 
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The Home Tab, Continued  

 
Plug-Ins, 

Tables, 

Wavemaker 

and Datalink 

Simulation, 

Continued 

This table continues to outline the capabilities available from the Plug-Ins, 

Tables, WaveMaker and Datalink Simulation sections of the Home tab 

toolbar. 

 

Icon Description 

 

Opens the J1939 Datalink Sensor Simulation 

Management window where J1939 messages can be 

defined. 

 

For more information about J1939 Datalink Sensor 

Simulation see Page 108. 

 
Manipulating 

Configuration 

Files 

The Configuration section of the Home tab toolbar provides the ability the 

work with configuration files. 

 

Icon Description 

 

Opens the Configuration File dialog box where a 

configuration can be selected and opened. 

 

Opens the Configuration File dialog box where a 

configuration file can be saved. 

Continued on next page 
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The Home Tab, Continued 

 
Manipulating 

Configuration 

Files 

This table continues to outline the capabilities available from the 

Configuration section of the Home tab toolbar. 

 

Icon Description 

 

Clears the configuration. 

 

Sends the currently open configuration to the LUIS 

Gen2 hardware. 

 
Saves the current values of all controls as the new 

defaults. 

 
Attaching Files The Attachments icon on the Home tab toolbar opens the Attachments 

window where the user can attach a document, such as a wiring diagram, to 

the configuration. Once a file has been attached, the <Detach and Save> 

button can be used to save the file to the hard drive, and the <Open> button 

can be used to attempt to open the file using the default program for the file 

type. 

 

 

Continued on next page 
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The Home Tab, Continued 

 
Defaults The Defaults icon on the Home tab toolbar opens the Options window where 

defaults can be set for startup, configuration and interface. 

 

The Startup defaults allow the user to set whether or not a configuration is 

loaded as well as if the Startup Page should be displayed at startup. 

 

 
 

The Configuration defaults allow the user to set what should happen after a 

configuration file is loaded as well as set a default configuration file. 

 

 

Continued on next page 
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The Home Tab, Continued 

 
Defaults, 

Continued 
The Interface defaults allow the user to set grid options for laying out 

controls on windows.  The F9 key toggles the snap option on and off. 
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Section 2 – The Tools Tab 

The Tools Tab 

 
Introduction Configuration files are built in user defined windows. The Tools tab provides 

the toolbar for adding windows in the workspace as well as tiles within 

windows. It also provides the interface for adding the desired controls to build 

the configuration. 

 
Definitions To easily work within the LUIS Gen2 GUI, it is necessary to understand some 

terminology. 

 

Term Definition 

Window A container in a configuration to which tiles 

can be added 

Tile A space within a window to which controls 

can be added and manipulated as a group. 

Every window has at least one tile. 

Digital Display A control that displays Engine Units, Counts 

and Millivolts digitally 

Gauge A control that displays values in a round or 

slider display 

Indicator A control that displays the status of resistive 

loads 

Text Panel A control that allows the user to add text to a 

configuration 

Switch A display that allows the user to add a 

momentary or toggle switch to the 

configuration 

Closed Loop Control A control that allows the user to create a 

simple closed loop engine speed model. This 

control is only available when using an ECM 

that outputs a public broadcast on the J1939 

datalink 

Dock The process of fixing the position of a 

window within the workspace 

Pin The process of fixing the position of a 

window within the workspace in a way that it 

“window shades” to the last docked position 

when not active 

Continued on next page 
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The Tools Tab, Continued 

 
In This Section This table outlines the topics covered in this section. 

 

Topic See Page 

Working with Windows 25 

Working with Tiles 40 

Working with Controls 48 
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Notes 
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Working with Windows 

 
Introduction Windows are the “containers” of tiles, and every window has at least one tile. 

Windows make up the base of a configuration file and display in the 

workspace. When a configuration file is saved, the position and status of all 

the windows are saved as well.  

 
Window Status 

and Positions 
Windows are placed within the workspace and can have one of four states: 

tabbed, dockable, dockable and floating or hidden. 

 

Status Description 

Tabbed When a window is tabbed, it remains in full screen 

mode and a tab with the window’s name displays 

at the top of the workspace. Tabbed windows 

cannot be moved or resized. 

Dockable When a window is dockable, it can be docked to 

the top, bottom, left or right side of the workspace. 

The width or length of the window can be adjusted 

from the dockable position by hovering over the 

edge of the window until the cursor changes to the 

re-sizing cursor. 

Dockable and Floating When a window is dockable and floating it floats 

above the workspace until it is re-docked. When 

the window is floating, it can be moved around the 

workspace by dragging it by the title bar. It can 

also be resized by hovering over the edges until 

the cursor changes to the re-sizing cursor.  

Hidden When a window is hidden, it no longer displays in 

the workspace. A hidden window can be unhidden 

by selecting it on the View tab. 

 
Pinned / 

Unpinned 
When a window is pinned, it will remain in the docked position whether it is 

the active window or not. When a window is unpinned, (auto hide), the 

window will “window shade” into a tab in the last docked position when not 

active. A window can be switched between pinned and unpinned by clicking 

the push pin icon in the upper right-hand corner of the window. 

Continued on next page 
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Working with Windows, Continued 

 
Window Status In this image, the Main window is currently docked to the left-hand side of 

the workspace and unpinned. It window shades to the left-hand side of the 

workspace when not active. The Frequency window is docked to the bottom 

of the workspace, and the rest of the windows are tabbed across the top of the 

workspace. 

 

 

Continued on next page 
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Working with Windows, Continued 

 
Adding 

Windows 
This table outlines the steps for adding a new window. 

 

Step Action 

1 Add a new window. 
 

Add Through… Action… 

Tools tab Click the Add Window icon 

Quick Access Toolbar Click the Add Window icon 

Workspace Right-click any empty spot in the 

workspace, not inside a tile, and 

select the Add Window Pane option 
  

Result: The Add Window Pane window displays, as shown in 

Figure 5. 

2 In the Dock Location section, select where the new window 

should be docked within the workspace. 

3 If the window should be unpinned, (window shade to the docked 

position when not active), select the Unpin checkbox. 

4 In the Window Name field, type the name for the window. 

5 In the Tile Layout section, type the minimum number of columns 

and rows. 

6 When the window has been defined, click the <Add> button. 

Result: The window is added to the workspace, as shown in 

Figure 6. Note that every window automatically has one tile called 

Default. 

Continued on next page 
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Working with Windows, Continued 

 
Figure 5: 

Add Window 

Pane 

This is an example of the Add Window Pane window. 

 

 

 
Figure 6: 

New Window 
This is an example of a new window added to the workspace that is docked to 

the top. 

 

 

Continued on next page 
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Working with Windows, Continued 

 
Changing a 

Window’s 

Status 

A window’s status can be changed between tabbed, dockable, dockable and 

floating and hidden in a couple of ways. This table describes changing status. 

 

Change Status To Action 

Floating To change any window’s status to floating, right-

click the title bar of the window and select the 

Floating option. A docked window can also be 

changed to floating by grabbing the window’s title 

bar and pulling it away from its docked position. 

When moving a window that is floating, the 

Docking tools, shown in Figure 8, display. 

Dropping a window in these tools automatically 

docks the window to the selected position in the 

workspace. Dropping a window in the middle of 

the center docking tools changes the window’s 

status to tabbed. 

Dockable To change a tabbed window’s status to dockable, 

right-click the title bar of the window and select 

the Dockable option. The window docks to the last 

docked position. 

Note: Pinned windows must be unpinned before 

they can be changed. 

Tabbed To change a window to the tabbed status, right-

click the title bar of the window and de-select the 

Dockable option. 

Alternatively, grab any window by the title bar and 

drag it to the middle of the center docking tools. 

Hidden To change any window’s status to hidden, right-

click the title bar of the window and select the 

Hidden option. Alternatively, click the X in the 

upper right-hand corner of the window’s title bar. 

To un-hide the window, go to the View tab and 

click on the window in the toolbar. 

Continued on next page 
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Working with Windows, Continued 

 
Figure 7: 

Window Status 
In this image, the Main window is currently unpinned and window shades to 

the left-hand side of the workspace. The Frequency window is docked to the 

bottom of the workspace, and the rest of the windows are tabbed across the 

top of the workspace. 

 

 

 
Figure 8 

Docking Tools 
This image shows the docking tools. 

 

 

Continued on next page 
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Working with Windows, Continued 

 
Rows and 

Columns 
Rows and columns within a window help organize the tiles within the widow. 

The number of rows and columns set in a window can be changed in a couple 

of ways.  

 

From the Tools tab, click the Modify Window icon to open the 

Modify/Delete Window Pane window, shown in Figure 9. Select the 

window to modify from the Window Panes field, and change the number of  

rows and/or columns on the right. When finished, click the <Apply> button 

and then <Close>. 

 

Right-click in any empty space in the window and select the Change Rows or 

Change Columns option. 

 
Renaming a 

Window 
A window’s name can be changed in a couple of ways.  

 

From the Tools tab, click the Modify Window icon to open the 

Modify/Delete Window Pane window. Select the window to modify from 

the Window Panes field  and change the window’s name on the right. When 

finished, click the <Apply> button and then <Close>. 

 

Right-click in any empty space in the window and select the Rename 

Window Pane option. 

 
Deleting a 

Window 
To permanently delete a window from the configuration, right-click in an 

empty space in the window and select the Delete Window Pane option from 

the menu. Alternatively, from the Tools tab, click the Modify Window icon 

to open the Modify/Delete Window Pane window. Select the window to 

delete from the Window Panes field and click the <Delete> button. 

 

Note: Clicking the X in the upper right-hand side of the title bar removes the 

window from the workspace but does not delete it from the configuration file. 

Continued on next page 
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Working with Windows, Continued 

 
Figure 9: 

Modify/ Delete 

Window Pane 

Window 

This is an example of the Modify/Delete Window Pane window. 

 

 

Continued on next page 
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Working with Windows, Continued 

 
Exercise: 

Working with 

Windows 

The purpose of this exercise is to familiarize users with the manipulation of 

windows in the LUIS Gen2 environment. This exercise assumes that the 

LUIS Gen2 hardware and software is already installed, the hardware is 

connected and turned on, and the software is open with no configuration file 

loaded.  

 

Step Action 

Open a configuration file  

1 If the Start window is displayed in the workspace, click the X on 

the right-hand side of the title bar to close it.  

2 On the Home tab, click the Open icon. 

Result: The Configuration File window displays. 

3 Locate the sample.l2c file, select it and click <Open>. 

Result: The configuration file loads. This configuration file has 7 

windows. The Main window is docked and unpinned to the left 

hand side of the screen and the remaining windows re tabbed. 

Add a window  

5 On the Tools tab, click the Add Window icon. 

Result: The Add Window Pane window displays, as shown in 

Figure 10 

6 In the Dock Location section, select the Bottom option. 

7 In the Window Name field, type Frequency. 

8 Leave the Tile Layout options set to the defaults of 1. 

9 Leave the Unpinned option un-selected. 

10 Click <Add> to add the window and <Close> to close the Add 

Window Pane window. 

Result: A new window called Frequency displays at the bottom 

of the workspace, as shown in Figure 11. 

11 Resize the Frequency window to display the controls in the 

Throttle tab. 

Continued on next page 
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Working with Windows, Continued 

 
Figure 10: 

Add Window 

Pane Window 

This image shows an example of the Add Window Pane window. 

 

 

 
Figure 11: 

New Frequency 

Window 

This image shows the workspace after adding the Frequency window to the 

sample configuration. 

 

 

Continued on next page 
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Working with Windows, Continued 

 
Exercise: 

Working with 

Windows, 

Continued 

The purpose of this exercise is to familiarize users with the manipulation of 

windows in the LUIS Gen2 environment. This exercise assumes that the 

LUIS Gen2 hardware and software is already installed, the hardware is 

connected and turned on, and the software is open with no configuration file 

loaded.  

 

Step Action 

Work with an unpinned window  

11 Locate the Main tab on the left-hand side of the workspace and 

hover over it. 

Result: The window slides out from the hidden position.  

12 Click the push pin icon in the right-hand corner of the title bar. 

Result: The window is now pinned to the workspace, as shown in 

Figure 12. The Main tab disappears from its location on the left-

hand side of the workspace. All the other windows resize to 

accommodate the new pinned window. 

13 Click the push pin icon in the right-hand corner of the title bar 

again 

Result: The window is now unpinned, in auto-hide mode, and 

slides back into the tab on the left-hand side of the workspace. 

Work with a floating window  

14 Right-click the title bar of the Frequency window and select the 

Floating option from the menu. 

Result: The window now floats above the workspace. 

15 Drag the Frequency window by the title bar and drop it on the 

middle of the center docking tools, shown in Figure 13. 

Result: The Frequency window is now a tabbed window and 

displays at the end of the other window tabs. 

16 Right-click on the Frequency tab and select the Dockable option 

from the menu. 

Result: The Frequency window returns to its docked position at 

the bottom of the workspace. 

Continued on next page 
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Working with Windows, Continued 

 
Figure 12: 

Pinned Engine 

Speed/Position 

Window 

This image shows the Main window in the pinned status. 

 

 

 
Figure 13: 

Floating to 

Tabbed 

Window 

This image shows dropping the Frequency floating window into the center 

docking tool. 

 

 

Continued on next page 



Page 38 

 

Working with Windows, Continued 

 
Exercise: 

Working with 

Windows, 

Continued 

The purpose of this exercise is to familiarize users with the manipulation of 

windows in the LUIS Gen2 environment. This exercise assumes that the 

LUIS Gen2 hardware and software is already installed, the hardware is 

connected and turned on, and the software is open with no configuration file 

loaded.  

 

Step Action 

Hide a window  

17 Click the X icon on the right-hand side of the Frequency window 

title bar. 

Result: The Frequency window is removed from the workspace. 

18 Go to the View tab, shown in Figure 14, and click the Frequency 

window icon. 

Result: The Frequency window returns to the workspace in its 

previous position. 

Delete a window  

19 On the Tools tab, click the Add Window icon. 

Result: The Add Window Pane window displays. 

20 In the Window Name field, type Testing and click <Apply>. 

Result: The new window is added to the workspace and the other 

windows resize to accommodate it. 

21 Click the <Close> button. 

Result: The Add Window Pane window closes. 

22 Right-click in the Testing window just above the Default tile and 

select the Delete Window Pane option, as shown in Figure 15. A 

dialog box displays to confirm the deletion. Click <Yes> to 

confirm. 

Result: The Testing window is removed from the workspace. 

Save a configuration  

23 Save the current configuration to a new configuration file name 

by clicking the LUIS icon in the upper left-hand side of the 

window and selecting the Save As option. 

Result: The Configuration File dialog box displays where the 

new filename and location can be set. 

Continued on next page 
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Working with Windows, Continued 

 
Figure 14: 

The View Tab 
This is an example of the View tab which shows all the windows in the 

configuration. 

 

 

 
Figure 15: 

Deleting a 

Window 

This is an example of the menu that displays when right-clicking within a 

window but not on a tile. 
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Working with Tiles 

 
Introduction Tiles are defined spaces within a window to which controls can be added. All 

the controls within a tile are moved and removed from a window as a group. 

Every window must have at least one tile. 

 
Adding Tiles Whenever a window is added to the workspace, a tile named Default is 

automatically created. Additional tiles can be added by clicking the Add Tile 

icon on the Tools tab. Alternatively, additional tiles can be added by right- 

clicking anywhere in a window and selecting the Add Tile option from the 

menu.  

 

If the number of rows and/or columns has been set for the window, the new 

tile will fill in the next open column or row. If the number of rows and 

columns has not been set, the new tile will fill in where it will fit. Figure 16 

shows an example of a window with two tiles. 

 
Renaming Tiles Tiles can be renamed using the Modify Tile dialog box, shown in Figure 17. 

This dialog box can be opened by right-clicking on a tile and selecting the 

Rename Tile option from the menu or by clicking the Modify Tile icon on 

the Tools tab. On the Modify Tile dialog box, select the window where the 

tile resides in the Window Panes field; select the tile in the Tiles field and 

type in a new name in the Tile Name field. 

 
Moving and 

Resizing Tiles 
Tiles can be moved by grabbing the title bar of the tile and dragging it to a 

new position within the window. 

 

Tiles automatically resize as the window is resized. One tile can be enlarged 

to occupy the majority of the window, decreasing the size of the others, by 

clicking the Enlarge icon in the upper right-hand side of the title bar. Figure 

18 shows an example of one tile being enlarged to occupy the majority of a 

tile. 

 
Clearing Tiles All controls can be removed from a tile by right-clicking in the tile and 

selecting the Clear Tile option from the menu 

 
Deleting Tiles Tiles can be deleted by right-clicking in the tile and selecting the Delete Tile 

option from the menu. Alternatively, tiles can be deleted using the <Delete> 

button on the Modify Tiles dialog box. 

Continued on next page 
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Working with Tiles, Continued 

 
Figure 16: 

Window with 

Two Tiles 

This is an example of a window with two tiles named Speed and Tach. 

 

 

 
Figure 17: 

Modify Tile 

Window 

This is an example of the Modify Tile window. 

 

 

 
Figure 18: 

Enlarged Tile 
This is an example of a window with two tiles where one tile is enlarged. 

 

 

Continued on next page 
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Working with Tiles, Continued 

 
Exercise: 

Working with 

Tiles 

The purpose of this exercise is to familiarize users with the manipulation of 

tiles in the LUIS Gen2 environment. This exercise assumes that the LUIS 

Gen2 hardware and software is already installed, the hardware is connected 

and turned on, and the software is open with the configuration file saved in 

the previous exercise open. 

 

Step Action 

Add a tile  

1 From the Tools tab, click the Add Tile icon. 

Result: The Add Tile window displays, as shown in Figure 19. 

2 In the Window Panes section, select the Frequency option. 

3 In the Tile Name field, type Tach. 

4 Click the <Add> button. 

Result: A new tile named Tach is added to the Frequency 

window. The Default tile shrinks to accommodate the new tile. 

Modify a Tile  

5 On the Tools tab, click the Modify Tile icon. 

Result: The Modify Tile window displays, as shown in Figure 

20. 

6 In the Window Panes section, select the Frequency option. 

7 In the Tile section, select the Default option. 

8 In the Tile Name field, type Speed. 

9 Click the <Apply> button. 

Result: The Default tile’s name changes to Speed. 

10 Click the <Close> button. 

Result: The Modify Tile window closes. 

Continued on next page 
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Working with Tiles, Continued 

 
Figure 19: 

Add Tile 

Window 

This is an example of the Add Tile window. 

 

 

 
Figure 20: 

Modify Tile 

Window 

This is an example of the Modify Tile window. 

 

 

Continued on next page 
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Working with Tiles, Continued 

 
Exercise: 

Working with 

Tiles 

The purpose of this exercise is to familiarize users with the manipulation of 

tiles in the LUIS Gen2 environment. This exercise assumes that the LUIS 

Gen2 hardware and software is already installed, the hardware is connected 

and turned on, and the software is open with the configuration file saved in 

the previous exercise open. 

 

Step Action 

Enlarge a tile  

11 Click the Enlarge icon in the upper right-hand corner of the 

Speed tile’s title bar. 

Result: The Speed tile expands within the Frequency window 

and the Tach tile automatically shrinks, as shown in Figure 21. 

12 Click the Switch to Normal Mode icon in the upper right-hand 

corner of the Speed tile’s title bar. 

Result: The Speed tile shrink back within the Frequency window 

and the Tach tile automatically resizes. 

Change tile configuration  

13 From the Tools tab, click the Modify Window icon. 

Result: The Modify/Delete Window Pane window opens, as 

shown in Figure 22. 

14 In the Window Panes section, select the Frequency option. 

15 In the Tile Layout section, change the Min Tile Rows to 2. 

16 Click the <Apply> button. 

Result: The tiles within the Frequency window are now stacked 

to fill the minimum 2 rows set for the window, as shown in 

Figure 23. 

17 Change the Min Tile Rows back to 1 and click the <Apply> 

button. 

Result: The tiles move back to one row and display next to each 

other. 

18 Click the <Close> button. 

Result: The Modify/Delete Window Pane window closes. 

Continued on next page 
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Working with Tiles, Continued 

 
Figure 21: 

Enlarged Tile 
This image is an example of one tile enlarged within a window. 

 

 

 
Figure 22: 

Modify/Delete 

Window Pane 

Window 

This is an example of the Modify/Delete Window Pane window. 

 

 

 
Figure 23: 

Window with 2 

Rows 

This image an example of a window with two tiles and a minimum of 2 rows. 

 

 

 

Continued on next page 
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Working with Tiles, Continued 

 
Exercise: 

Working with 

Tiles 

The purpose of this exercise is to familiarize users with the manipulation of 

tiles in the LUIS Gen2 environment. This exercise assumes that the LUIS 

Gen2 hardware and software is already installed, the hardware is connected 

and turned on, and the software is open with the configuration file saved in 

the previous exercise open. 

 

Step Action 

Reorganize tiles  

19 Grab the title bar of the Speed tile and drag it to the other side of 

the Tach tile. 

Result: The Speed tile moves to the other side of the Tach tile, as 

shown in Figure 24. 

Deleting tiles  

20 Right-click on one of the tiles in the Frequency window and 

select the Add Tile option. 

Result: The Tile Creation Entry widow displays. 

21 In the field, type Test and click <OK>. 

Result: A new tile named Test is added to the Frequency 

window. 

22 Right-click on the Test tile and select the Delete Tile option. A 

dialog box displays to confirm the deletion. Click <Yes> to delete 

the tile. 

Result: The tile is removed and the other tiles automatically 

resize. 

Save a configuration  

23 Save the current configuration by clicking the Save icon on the 

Home toolbar. 

Result: The Configuration File is saved. 

Continued on next page 
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Working with Tiles, Continued 

 
Figure 24: 

Window with 

Two Tiles 

This is an example of a window with two tiles named Speed and Tach. 
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Working with Controls 

 
Introduction Controls are the gauges, switches, digital displays and text that display the 

values from the hardware. This section gives an overview of how to work 

with the control on the Tools Tab. For more information about each specific 

control, see Chapter 7 – Controls beginning on page 136. 

 
Adding 

Controls 
Controls are added to tiles within windows; they cannot sit directly on a 

window. To add a control, grab the desired control icon from the Tools tab 

and drag it to the desired tile. 

 
Moving 

Controls 
A control can be moved within the same tile by grabbing its title bar and 

dragging it to a new position. The grid spacing as well as whether or not 

controls should be snapped to the grid are set on the Interface Options tab on 

the Options window opened through the Defaults icon on the Home tab. 

 
Copying and 

Pasting 

Controls 

Any control can be copied by right-clicking on the control and selecting the 

Copy option from the menu, shown in Figure 25. To paste a control, right-

click where the new control should be pasted and select the Paste option from 

the menu. Controls can be pasted between tiles and windows within an 

instance of the LUIS Gen2 GUI. Controls can also be pasted between 

multiple instances of the LUIS Gen2 GUI open on the same PC. 

 
Paste Special The properties of any control can be pasted onto another control by right-

clicking on the original control and selecting the Copy option from the menu 

and then right-clicking on the recipient control and selecting the Paste 

Special option. The Paste Special dialog box, shown in Figure 26, displays 

where the user can select what properties should be pasted onto the control. 

These options include both appearance and operation. 

Continued on next page 
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Working with Controls, Continued 

 
Figure 25: 

Working with 

Controls 

This image depicts the menu that displays when right-clicking on a control. 

 

 

 
Figure 26: 

Paste Special 
This image depicts the Paste Special dialog box. 

 

 

Continued on next page 
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Working with Controls, Continued 

 
Resizing 

Controls 
A control can be resized by right-clicking on it and selecting the Allow 

Resizing option. Once resizing has been activated, click and drag the edges of 

the control to resize it. Once the control is the desired size, right-click it and 

select the Lock Size option to prevent accidentally resizing again. 

 
Deleting 

Controls 
To delete a control, right-click on the control and select the Delete option. 

 
Formatting 

Controls 
To format a control, right-click the control and select the Properties option 

from the menu. The ToolBox dialog box opens, as shown in Figure 27. The 

properties list varies with the type of control being formatted. For more 

information about formatting controls, see Chapter 7 – Controls beginning 

on page 136. 

Continued on next page 
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Working with Controls, Continued 

 
Figure 27: 

The Toolbox 

Dialog Box 

This is an example of the Toolbox dialog box. The options available in the 

Toolbox depend on the type of control selected. 

 

 

Continued on next page 
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Working with Controls, Continued 

 
Exercise: 

Working with 

Controls 

The purpose of this exercise is to familiarize users with the manipulation of 

controls in the LUIS Gen2 environment. This exercise assumes that the LUIS 

Gen2 hardware and software is already installed, the hardware is connected 

and turned on, and the software is open with the configuration file saved in 

the previous exercise open. 

 

Step Action 

Adding controls  

1 On the Tools tab, grab and drag the Gauge icon to the Speed tile 

on the Frequency window. 

Note: When the gauge is dropped on the window a warning 

symbol displays on it. This indicates that the control has not yet 

been configured. 

Formatting a control’s operation  

2 Right-click on the gauge in the Speed tile on the Frequency 

window and select the Properties option from the menu. 

Result: The Toolbox dialog box displays, as shown in Figure 28. 

3 In the Hardware section, next to the Hardware Setup field, click 

the <…> button. 

Result: The Hardware I/O Selection dialog box displays, as 

shown in Figure 29. 

4 In the Hardware Unit field, select Wavemaker. 

Result: The Channel field populates with the available channels 

in the selected hardware unit. 

5 In the Channel field, select Digital_CH#1 and click <OK>. 

Result: The Hardware I/O Selection dialog box closes and the 

Channel and Type fields are completed on the Toolbox dialog 

box. 

Continued on next page 
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Working with Controls, Continued 

 
Figure 28: 

The Toolbox 

Dialog Box 

This is an example of the Toolbox dialog box. 

 

 

 
Figure 29: 

Hardware I/O 

Selection Dialog 

Box 

This is an example of the Hardware I/O Selection dialog box. 
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Working with Controls, Continued 

 
Exercise: 

Working with 

Controls 

The purpose of this exercise is to familiarize users with the manipulation of 

controls in the LUIS Gen2 environment. This exercise assumes that the LUIS 

Gen2 hardware and software is already installed, the hardware is connected 

and turned on, and the software is open with the configuration file saved in 

the previous exercise open. 

 

Step Action 

6 In the Interpolation Table section, in the Table Name field, 

select the FREQ option from the dropdown list.  

7 In the Scale section, in the Maximum field, type 3000. 

Note: The scale on the gauge changes. 

8 In the Scale section, in the Minimum field, type 1. 

9 In the Scale section, in the Multiplier field, type 1. 

10 In the Server section, in the Name field, select WaveMaker_#1 

from the dropdown list. 

11 In the Text section, in the TextLine1 field, type ENGINE SPEED. 

Result: The text on the gauge changes. 

12 In the Text section, in the TextLine2 field, type RPM. 

Result: The text on the gauge changes. 

Formatting a control’s appearance  

13 On the Toolbox dialog box, in the Appearance section, click the 

drop-down arrow next to the Background Color field. From the 

drop-down, pick the Web tab and select the Dark Red option. 

Result: The background color of the gauge changes.  

14 In the Gauge Font section, click the <…> button. 

Result: The Font dialog box displays. 

15 In the Size field, type 6 and click <OK>. 

Result: The Font dialog box closes and the size of the gauge font 

changes.  

16 Close the Toolbox dialog box.  

Continued on next page 
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Working with Controls, Continued 

 
Figure 30: 

The Toolbox 

Dialog Box 

This is an example of the Toolbox dialog box. 

 

 

 
Figure 31: 

Modified 

Gauge 

This image shows the gauge after the modifications have been made. 

 

 

Continued on next page 
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Working with Controls, Continued 

 
Exercise: 

Working with 

Controls 

The purpose of this exercise is to familiarize users with the manipulation of 

controls in the LUIS Gen2 environment. This exercise assumes that the LUIS 

Gen2 hardware and software is already installed, the hardware is connected 

and turned on, and the software is open with the configuration file saved in 

the previous exercise open. 

 

Step Action 

Resizing controls  

17 Right-click on the gauge and select the Allow Resizing option 

from the menu. 

Result: The gauge can now be resized by grabbing the outline of 

the gauge and pulling it in and out. 

18 When the gauge has been resized, right-click on it and select the 

Lock Size option from the menu. 

Result: The gauge’s size is now locked. 

Moving controls  

19 Grab the gauge control by the title bar and drag it to a new 

position on the tile. 

Copying and pasting controls  

20 Right-click on the gauge and select the Copy option from the 

menu. 

21 Right-click anywhere in the current tile or another tile and select 

the Paste option. 

Result: A copy of the gauge is pasted on the tile. 

Deleting controls  

22 Right-click on the gauge that was just pasted and select the Delete 

option from the menu. 

Result: The control is removed from the tile. 

Continued on next page 
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Working with Controls, Continued 

 
Figure 32: 

Formatted 

Gauge 

This is an example of the formatted gauge on the Frequency window. 

 

 

Continued on next page 
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Working with Controls, Continued 

 
Exercise: 

Working with 

Controls 

The purpose of this exercise is to familiarize users with the manipulation of 

controls in the LUIS Gen2 environment. This exercise assumes that the LUIS 

Gen2 hardware and software is already installed, the hardware is connected 

and turned on, and the software is open with the configuration file saved in 

the previous exercise open. 

 

Step Action 

Paste Special  

23 Right-click on the ENGINE SPEED gauge in the Frequency 

window and select the Copy option. 

24 Right-click on the THROTTLE gauge in the Throttle window 

tab and select the Paste Special option. 

Result: The Paste Special dialog box displays, as shown in Figure 

33. 

25 Ensure the Background Color and Component Font options are 

selected and all other are deselected. Then click <OK>. 

Result: The background color and component font properties 

from the ENGINE SPEED gauge are applied to the THROTTLE 

gauge, as shown in Figure 34. 

Save a configuration  

26 Save the current configuration by clicking the Save icon on the 

Home toolbar. 

Result: The Configuration File is saved. 

Continued on next page 
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Working with Controls, Continued 

 
Figure 33: 

Paste Special 
This image depicts the Paste Special dialog box. 

 

 

 
Figure 34: 

Reformatting 

Control 

This is an example of pasting options from one gauge to another. 
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Section 3 – The View and Help Tabs 

The View and Help Tabs 

 
The View Tab The View tab is a way to easily navigate between all windows within a 

configuration whether or not they are hidden. It is also the way to unhide a 

hidden window. 

 

 

 
The Help Tab The Help tab provides information about the current version of LUIS as well 

as on-line help. 
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Section 4 – Printing a Configuration File Summary 

Printing a Configuration File Summary 

 
Introduction LUIS Gen2 provides the ability to print a summary of all the controls within a 

configuration. 

 
Configuration 

File Summary 
The Configuration File dialog box displays all the controls in the 

configuration listed by server. To open the Configuration File dialog box, 

click the LUIS icon in the upper left-hand corner of the application and select 

the Print option.  

 

The Configuration File dialog box, shown in Figure 35, provides a toolbar 

for navigating the summary as well as setting up the print options. This table 

and image describe the options on the toolbar. 

 

 
 

Icon Description 

 
These icons are used to navigate through the 

pages of the summary within the Configuration 

File dialog box. 

 
This icon is used to refresh the control list. 

 
This icon is used to open the Print dialog box to 

print the summary. 

 
This icon is used to toggle between a print 

preview view and the standard view. 

 
This is used to set up the print options such as 

margins and orientation. 

 
This icon is used to export the file in either MS 

Excel or Adobe PDF format. 

 
This icon is used to set the size of the view within 

the Configuration File dialog box. 

 
These icons are used to search for text within the 

Configuration File dialog box. 

Continued on next page 
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Printing a Configuration File Summary, Continued 

 
Figure 35: 

Example 

Configuration 

File Dialog Box 

This is an example of a configuration in the Configuration File dialog box. 
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Notes 
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Chapter 3 –Interpolation Tables 

Overview 

 
Introduction Some of the components controlled by the LUIS Gen2 require an 

interpolation table to match the engineering unit that is on the gauge to a 

counts value. For example 32 PSI is 500 counts, which is a specific voltage 

that LUIS Gen2 outputs. The Table Management window within the LUIS 

Gen2 GUI provides the capability for building interpolation tables. 

 
In This 

Chapter 
This table outlines the topics covered in this chapter. 

 

Topic See Page 

Creating an Interpolation Table 66 

Editing an Interpolation Table 72 

Importing an Interpolation Table 74 

Deleting an Interpolation Table 76 
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Section 1 – Creating an Interpolation Table 

Creating an Interpolation Table 

 
Introduction Interpolation tables can be created from the Home tab by clicking the Tables 

icon. The data can be entered manually or cut and pasted from another 

application such as Microsoft Excel. 

 
Creating an 

Interpolation 

Table 

This table outlines the steps for creating an interpolation table. 

 

Step Action 

1 From the Home tab, click the Tables icon. 

Result: The Table Management window opens, as shown in 

Figure 36. 

2 Click the <Add New> button. 

Result: The New Table Creation dialog box displays, as shown 

in Figure 37. 

3 In the field, type the name of the new interpolation table and click 

<OK>. 

Result: The new table name displays in the name field and the 

default values fill in the other fields. The table name also displays 

in the Tables field on the left-hand side of the frame. 

4 In the Input Units field, type the engineering units of the table 

input or use None. 

5 In the Output Units field, type the units of the table output. 

6 In the Resolution Scalar field, type the multiplier that should be 

used to match the table output to the hardware limitations. 

Example: If the table output is set up for 10 bit, (1023 counts), 

and the hardware output is 16 bit, (65535 counts), then the 

conversion formula is Hardware Output / Table Output or 

65535/1023 = 64. The resolution scalar is 64. 

Continued on next page 
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Creating an Interpolation Table, Continued 

 
Figure 36: 

Table 

Management 

Window 

This is an example of the Table Management window. 

 

 

 
Figure 37: 

New Table 

Creation Dialog 

Box 

This is an example of the New Table Creation dialog box. 

 

 

Continued on next page 
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Creating an Interpolation Table, Continued 

 
Creating an 

Interpolation 

Table, 

Continued 

This table continues to outline the steps for creating an interpolation table. 

 

Step Action 

7 In the Notes section, type any notes to describe the table. 

8 The Min Value (mV) field is the minimum hardware value used to 

calculate output voltages when digital to analog converters are 

used. The value is typically 0 mV. 

Note: This is only used for display purposes and does not affect 

hardware output. 

9 The Max Value (mV) field is the maximum hardware value used 

to calculate output voltages when digital to analog converters are 

used. The value is typically 5000 mV. 

Note: This is only used for display purposes and does not affect 

hardware output. 

10 The Max Raw Value field is the value used to calculate output 

voltages when digital to analog converters are used. A typical 

table would be set up for 10 bit output and a max raw value of 

1023 would be needed. 

Note: This is only used for display purposes and does not affect 

hardware output. 

Continued on next page 
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Creating an Interpolation Table, Continued 

 
Figure 38: 

Table 

Management 

Window 

This is an example of the Table Management window. 

 

 

Continued on next page 
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Creating an Interpolation Table, Continued 

 
Creating an 

Interpolation 

Table, 

Continued 

This table continues to outline the steps for creating an interpolation table. 

 

Step Action 

11 Once the interpolation table is set up, the table values should be 

entered. 

Note: Before entering values, ensure that the correct table is 

highlighted in the Tables list. 
 

To… Then… 

Enter values manually Type the values into the table 

on the left-hand side of the 

window using the TAB key to 

move between fields. 

Paste from another program  Copy the values from the 

other program. 

Return to the Table 

Management window and 

right-click in the first cell of 

the table on the left-hand side 

and select Paste from the 

menu. 

  

12 Once the table has been set up and the values have been entered, 

click the <Save> button. 

Result: The interpolation table is saved and will be available in 

the Interpolation Table Table Name drop-down list for 

formatting controls. 

13 Close the Table Management window and save the 

configuration file. 

Continued on next page 
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Creating an Interpolation Table, Continued 

 
Figure 39: 

Table 

Management 

Window 

This is an example of the Table Management window. 
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Section 2 – Editing an Interpolation Table 

Editing an Interpolation Table 

 
Introduction Interpolation tables can be edited if the set up for the table or the values in the 

table need to change. 

 
Editing an 

Interpolation 

Table 

This table outlines the steps for editing an interpolation table. 

 

Step Action 

1 Ensure that the correct configuration file is open and then from 

the Home tab, click the Tables icon. 

Result: The Table Management window displays, as shown in 

Figure 40. 

2 In the Tables list, highlight the table to edit. 

Result: The setup information displays on the right-hand side of 

the window and the table data is filled in on the left-hand side. 

3 Make the required changes to the setup and/or the data. 

4 Click the <Save> button. 

Result: The changes are saved. 

5 Close the Table Management window and save the 

configuration file. 

Continued on next page 
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Editing an Interpolation Table, Continued 

 
Figure 40: 

Table 

Management 

Window 

This is an example of the Table Management window. 
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Section 3 – Importing an Interpolation Table 

Importing an Interpolation Table 

 
Introduction An existing interpolation table can be imported into a configuration file. LUIS 

Gen2 can import both Gen1 and Gen2 files. 

 
Importing and 

Interpolation 

Table 

This table outlines the steps for importing an interpolation table. 

 

Step Action 

1 Ensure that the correct configuration file is open then from the 

Home tab, click the Tables icon. 

Result: The Table Management window displays, as shown in 

Figure 41. 

2 Click the <Import> button. 

Result: The Import Tables dialog box displays. 

3 Browse for and select the appropriate configuration file that 

contains the desired interpolation table. 

Note: To import a Gen1 file or other text file, select .txt instead of 

.l2c in the file type dropdown list. 

4 Click the <Open> button. 

Result: The Select Items window, shown in Figure 42, displays 

with all the interpolation tables in that configuration file. 

5 Select each of the interpolation tables to import and click the 

<Import> button. 

Note: If all the interpolation tables should be imported, click the 

<Select All> button. 

Result: The selected table(s) is/are imported and display in the 

Tables list on the Table Management window. 

6 Close the Table Management window and save the 

configuration file. 

Continued on next page 
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Importing an Interpolation Table, Continued 

 
Figure 41: 

Table 

Management 

Window 

This is an example of the Table Management window. 

 

 

 
Figure 42: 

Select Items 

Window 

This is an example of the Select Items window. 
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Section 4 – Deleting an Interpolation Table 

Deleting an Interpolation Table 

 
Introduction If an interpolation table is no longer needed in a configuration, it can be 

deleted. An interpolation table can only be deleted if it is not associated with 

any control within the configuration. 

 
Deleting an 

Interpolation 

Table 

This table outlines the steps for deleting an interpolation table. 

 

Step Action 

1 Ensure that the correct configuration file is open then from the 

Home tab, click the Tables icon. 

Result: The Table Management window displays, as shown in 

Figure 43. 

2 In the Tables list, highlight the table to delete. 

3 Click the <Delete> button. 

Result: A dialog box displays to confirm the action. Click yes to 

delete the table. The table is removed from the Tables list and the 

configuration file. 

4 Close the Table Management window and save the 

configuration file. 

Continued on next page 
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Deleting an Interpolation Table, Continued 

 
Figure 43: 

Table 

Management 

Window 

This is an example of the Table Management window. 
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Chapter 4 – Waveforms 

Overview 

 
Introduction The Wavemaker module has built in support for specific waveform data. 

LUIS Gen2 supports both Generation 1 and Generation 2 waveform 

management. Generation 1 uses the Peak Adapter servers, and the available 

waveforms are resident in the firmware. Generation 2 uses the WaveMaker 

servers, and users can define and import waveforms. Each waveform must 

have a unique name within a configuration file. The Wavemaker 

Management window is used for viewing and defining waveforms as well as 

for assigning waveforms to channels. 

 
In This 

Chapter 
This table outlines the topics covered in this chapter. 

 

Topic See Page 

Working with Gen2 Waveforms 79 

Working with Gen1 Waveforms 98 
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Section 1 – Working with Gen2 Waveforms 

Overview 

 
Introduction LUIS Gen2 waveforms use the WaveMaker server. The user defines the 

waveforms on the server and then assigns these waveforms to either digital or 

arbitrary channels. LUIS Gen2 has 8 specific arbitrary channels and 10 

specific digital channels. 

 
In This Section This table outlines the topics covered in this section. 

 

Topic See Page 

Defining a  Gen2 Waveform 80 

Importing a Gen2 Waveform 84 

Renaming a Gen2 Waveform 86 

Assigning a Gen2 Waveform 88 

Exercise: Defining and Assigning a Gen2 Waveform 94 
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Defining a Gen2 Waveform 

 
Introduction Waveforms are defined within a configuration on the Waveform 

Management window. The left-hand side of this window provides the 

interface for defining waveforms as well as maintaining a list of all the 

waveforms in this configuration. 

 
Defining a 

Gen2 

Waveform 

This table outlines the steps for defining a waveform. 

 

Step Action 

1 With the appropriate configuration file open, from the Home tab, 

click the Waveforms/Channels icon. 

Result: The WaveMaker Management window displays, as 

shown in Figure 44. 

2 Click the LUIS Gen2 tab at the top of the window. 

Result: The interface for defining Gen2 waveforms and assigning 

them to channels displays. 

3 On the left-hand side of the window in the Waveform Definition 

section, click the <Add New> button. 

Result: The New Waveform Creation dialog box displays, as 

shown in Figure 45. 

4 In the field, type the name of the waveform and click <OK>. 

Result: The name displays in the Name field as well as being 

listed in the waveform library field. 

5 In the Card Output (mv) table, create the waveform. 
 

To… Then… 

Create manually Type in the values for the 

waveform using the TAB key 

to navigate the table. 
  

Continued on next page 
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Defining a Gen2 Waveform, Continued 

 
Figure 44: 

WaveMaker 

Management 

Window 

This is an example of the WaveMaker Management window open to the 

LUIS Gen2 tab. 

 

 

 
Figure 45: 

New Waveform 

Creation Dialog 

Box 

This is an example of the New Waveform Creation dialog box. 

 

 

Continued on next page 
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Defining a Gen2 Waveform, Continued 

 
Defining a 

Gen2 

Waveform, 

Continued 

This table continues to outline the steps for defining a waveform. 

 

Step Action 

5 Continued… 
 

To… Then… 

Copy from an alternate source 

such as Microsoft Excel 

Open the source and copy the 

data. 

Return to the WaveMaker 

Management window, right-

click in the first cell and select 

the Paste option from the 

menu. 
  

6 As the waveform data is entered, the Length field is automatically 

populated with the number of cells. 

7 When the waveform has been defined, click the <Save> button. 

Note: To save the changes permanently to the configuration file, 

click the <Save> icon on the LUIS Home tab. 

Continued on next page 
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Defining a Gen2 Waveform, Continued 

 
Figure 46: 

WaveMaker 

Management 

Window 

This is an example of the WaveMaker Management window open to the 

LUIS Gen2 tab. 
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Importing a Gen2 Waveform 

 
Introduction Waveforms can be imported from other configuration files. Remember that 

each waveform within a configuration file must have a unique name. The next 

section describes how to rename a waveform. 

 
Importing a 

Gen2  

Waveform 

This table outlines the steps for importing a waveform. 

 

Step Action 

1 With the appropriate configuration file open, from the Home tab, 

click the Waveforms/Channels icon. 

Result: The WaveMaker Management window displays, as 

shown in Figure 47. 

2 Click the LUIS Gen2 tab at the top of the window. 

Result: The interface for defining Gen2 waveforms and assigning 

them to channels displays. 

3 On the left-hand side of the window in the Waveform Definition 

section, click the <Import> button. 

Result: The Import Waveform dialog box displays. 

4 Browse for and select the configuration file that has the desired 

waveform(s) and click the <Open> button. 

Result: The Select Items window, shown in Figure 48, displays 

listing all the waveforms defined in the selected configuration 

file. 

Note: To select a Gen1 waveform file, change the file type 

dropdown list from .l2c to .cff. 

5 Select the waveform(s) to import and click the <Import> button. 

Note: To import all the waveforms in the configuration, click the 

<Select All> button. 

Result: The waveforms selected are imported and display in the 

library field. 

Continued on next page 
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Importing a Gen2 Waveform, Continued 

 
Figure 47: 

WaveMaker 

Management 

Window 

This is an example of the WaveMaker Management window open to the 

LUIS Gen2 tab. 

 

 

 
Figure 48: 

Select Items 

Window 

This is an example of the Select Items window. 
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Renaming a Gen2 Waveform 

 
Introduction After a waveform has been defined, its name can be changed through the 

WaveMaker Management window. 

 
Renaming a 

Gen2  

Waveform 

This table outlines the steps for renaming a waveform. 

 

Step Action 

1 With the appropriate configuration file open, from the Home tab, 

click the Waveforms/Channels icon. 

Result: The WaveMaker Management window displays. 

2 Click the LUIS Gen2 tab at the top of the window. 

Result: The interface for defining Gen2 waveforms and assigning 

them to channels displays. 

3 On the left-hand side of the window, in the waveform library 

field, highlight the waveform to rename. 

Result: The waveform’s data displays. 

4 Click the <Rename> button. 

Result: The Rename Waveform dialog box, shown in Figure 49, 

displays. 

5 Type the new name for the waveform and click <OK>. 

Result: The dialog box closes and the name of the waveform is 

changed in both the Name field and waveform library list. 

Note: The change is automatically saved to the waveform, but the 

configuration needs to be saved to make the changes permanent 

in the configuration file. 

Continued on next page 
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Renaming a Gen2 Waveform, Continued 

 
Figure 49: 

Rename 

Waveform 

Dialog Box 

This image depicts the Rename Waveform dialog box. 

 

 

Continued on next page 
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Assigning a Gen2 Waveform 

 
Introduction After waveforms have been defined, they can be assigned to channels on the 

WaveMaker Management window. The same waveform can be assigned to 

multiple channels within a configuration. 

 
Hardware 

Synchronizing 
Channels can be set to be synchronized. When using this option, one channel 

must be set to be the master. Any channel that should sync with that channel 

will be a slave to it.  

 

Channels can also be synchronized with an external drive. When this is the 

case, the master channel must be set as a master and also as an external sync 

drive. This allows the channel to output its drive signal externally and other 

WaveMaker units can use it as a master. 

 
Assigning a 

Gen2 

Waveform 

This table outlines the steps for assigning a waveform to a channel. 

 

Step Action 

1 With the appropriate configuration file open, from the Home tab, 

click the Waveforms/Channels icon. 

Result: The WaveMaker Management window displays, as 

shown in Figure 50. 

2 Click the LUIS Gen2 tab at the top of the window. 

Result: The interface for defining Gen2 waveforms and assigning 

them to channels displays. 

3 In the Server field, select the correct server for the channel to 

assign. 

Result: The channels available on the selected server display in 

the channels list and the first channel’s information is filled in to 

the fields. 

4 Select the desired channel from the channel list. 

Result: The channel’s information populates the fields. 

5 In the Input field, select the correct input. 

Continued on next page 
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Assigning a Gen2 Waveform, Continued 

 
Figure 50: 

WaveMaker 

Management 

LUIS Gen2 

Window  

This is an example of the WaveMaker Management window when 

assigning a LUIS Gen2 waveform. 

 

 

Continued on next page 
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Assigning a Gen2 Waveform, Continued 

 
Assigning a 

Gen2 

Waveform, 

Continued 

This table continues to outline the steps for assigning a waveform to a 

channel. 

 

Step Action 

6 In the Hardware Synchronizing section, select if this channel 

should be a Master, Slave or Master and External Sync Drive. 

Note: Unless this channel is to be a slave to another, the Master 

option should be selected. 

7 If the channel is a Slave, select its Master Channel from the 

dropdown list. 

Note: If this channel is to sync to an external sync drive, select 

the Ext Sync Drive option. This channel will automatically sync 

with whichever channel on the external sync drive was set up as 

the external sync master. 

8 The Card Settings section will differ depending on whether the 

user is defining an arbitrary or digital channel. 
 

Channel Type Settings 

Arbitrary In the Waveform field, select the 

desired waveform from the list. 

Note: Only waveforms in this 

configuration are available. 

If the Input setting is set to RPM, the 

Cycles/Rev must be set correctly to 

complete the required calculations. In 

the Cycles/Rev field, type the number 

of cycles per revolution for the 

waveform data pattern. 

Note: Two revolutions are typically 

used to make a complete cycle of data. 

The Offset field allows arbitrary 

channels that sync with each other to 

shift the waveform by a number of 

data points. If an offset is required, 

type the amount to offset in this field. 

 
 

Continued on next page 
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Assigning a Gen2 Waveform, Continued 

 
Figure 51: 

WaveMaker 

Management 

Window  

This is an example of the WaveMaker Management window when defining 

an arbitrary channel for LUIS Gen2. 

 

 

Continued on next page 
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Assigning a Gen2 Waveform, Continued 

 
Assigning a 

Gen2  

Waveform, 

Continued 

This table continues to outline the steps for assigning a waveform to a 

channel. 

 

Step Action 

8 Continued 
 

Channel Type Settings 

Digital In the Output field, select the correct 

output type. 

If the number of teeth per revolution 

of the flywheel is necessary, enter this 

number in the Teeth/Rev field. 

If PWM operation is desired for the 

channel, enter its heart beat frequency 

in the PWM HB Freq field. If PWM 

operation is not desired, this value 

should be set to 0. 

 
 

9 When all the assignments have been made, click the <Save> 

button. 

Note: This button saves the changes to the waveforms, but the 

configuration needs to be saved to make the changes permanent 

in the configuration file. 

Continued on next page 
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Assigning a Gen2 Waveform, Continued 

 
Figure 52: 

WaveMaker 

Management 

Window  

This is an example of the WaveMaker Management window when defining 

a digital channel for LUIS Gen2. 
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Exercise: Defining and Assigning a Gen2 Waveform 

 
Exercise: 

Defining and 

Assigning a 

Gen2 

Waveform 

The purpose of this exercise is to familiarize the user with using the 

WaveMaker Management window to define and assign Gen2 waveforms. 

 

Step Action 

Define a waveform  

1 On the Home tab, click the Waveforms/Channels icon. 

Result: The WaveMaker Management window opens, as shown 

in Figure 53. 

2 Click the LUIS Gen2 tab at the top of the window. 

Result: The interface for working with Gen2 waveforms displays. 

3 On the left-hand side of the window, in the Waveform 

Definition section, click the <Add New> button. 

Result: The New Waveform Creation window displays. 

4 In the field, type 60-2 Missing Teeth Test and click <OK>. 

Result: The new waveform is added to the waveform library list 

and the name displays in the Name field. 

5 In the Card Output table, fill in the value displayed in the image 

on the facing page. 

Result: As the table is populated, the Length field reflects the 

number of values in the table. 

6 Click the <Save> button. 

Result: The waveform is saved to the library. It is important to 

note that if the configuration file is closed without saving, this 

waveform will be lost. 

Continued on next page 
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Exercise: Defining and Assigning a Gen2 Waveform, Continued 

 
Figure 53: 

Table 

Definition 

This image displays the value for the table being created in Step 5. 

 

 

Continued on next page 
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Exercise: Defining and Assigning a Gen2 Waveform, Continued 

 
Exercise: 

Defining and 

Assigning a 

Waveform, 

Continued 

The purpose of this exercise is to familiarize the user with using the 

WaveMaker Management window to define and assign waveforms. 

 

Step Action 

Assign a waveform  

7 On the right-hand side of the WaveMaker Management 

window, in the Channel Definition section, from the Server 

dropdown list, select WaveMaker_#1. 

Result: The list of channels available in WaveMaker_#1 display 

in the channel list field. The first channel is highlighted, and its 

information displays in the fields. 

8 Ensure that Arbitrary_CH#1 is highlighted in the channels list. In 

the Arbitrary Card Settings section, from the Waveform 

dropdown list, select 60-2 Missing Teeth Test. 

9 Click the <Save> button. 

10 In the channel list field, click on Arbitrary_CH#2. 

Result: The fields are filled with the information for this channel. 

11 In the Hardware Synchronizing section, select the Slave option. 

12 From the Master Channel select the Arbitrary_CH#1 option. 

Note: This sets Arbitrary_CH#2 to be synced with 

Arbitrary_CH#1. 

13 In the Arbitrary Card Settings section, from the Waveform 

dropdown list, select 60-2 Missing Teeth Test. 

14 Click the <Save> button. 

Result: The waveform information is saved. 

15 Close the WaveMaker Management window and save the 

configuration. 

Continued on next page 
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Exercise: Defining and Assigning a Gen2 Waveform, Continued 

 
Figure 54: 

Assigning a 

Waveform 

This image is an example of assigning a waveform. 
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Notes 
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Section 2 – Working with Gen1 Waveforms 

Overview 

 
Introduction LUIS Gen1 waveforms use the Peak Adapter servers. The waveforms are all 

resident in the firmware and cannot be modified by the user. Because of the 

way the Gen1 firmware was coded, Gen1 waveforms must be loaded into 

Channel 1. The waveform combination will automatically be loaded into 

Channel 1 and Channel 2. The WaveMaker Management window is used to 

assign the desired waveform into Channel 1. 

 
In This Section This table outlines the topics covered in this section. 

 

Topic See Page 

Assigning a Gen1 Waveform 100 

Exercise: Assigning a Gen1 Waveform 106 
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Assigning a Gen1 Waveform 

 
Introduction All Gen1 waveforms are resident in the firmware, and they can be assigned to 

Channel 1 on the WaveMaker Management window. 

 
Hardware 

Synchronizing 
Channels can be set to be synchronized. When using this option, Channel #1 

will be used as the master, and any other channel that is set to sync will be a 

slave to that channel. 

 
Assigning a 

Gen1 

Waveform 

This table outlines the steps for assigning a waveform to a channel. 

 

Step Action 

1 With the appropriate configuration file open, from the Home tab, 

click the Waveforms/Channels icon. 

Result: The WaveMaker Management window displays. 

2 Click the LUIS Gen1 tab at the top of the window. 

Result: The interface for assigning the Gen1 waveforms resident 

in the firmware displays, as shown in Figure 55. 

3 In the Server field, select the correct server for the channel to 

assign. 

4 To assign a waveform, ensure that Channel#1 is selected. If 

setting up a digital channel, select the desired channel from the 

list. 

Result: The channel’s information populates the fields. 

5 In the Input field, select the correct input. 

6 In the Channel Definition section, select Arbitrary, Digital, or 

Digital Simulation. 

Note: Waveforms can only be assigned to arbitrary channels. 

7 If this channel should be synced to Channel #1, select the Sync 

option. 

Continued on next page 
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Assigning a Gen1 Waveform, Continued 

 
Figure 55: 

WaveMaker 

Management 

LUIS Gen1 

Window  

This is an example of the WaveMaker Management window open to the 

LUIS Gen1 tab. 

 

 

Continued on next page 
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Assigning a Gen1 Waveform, Continued 

 
Assigning a 

Gen1  

Waveform, 

Continued 

This table continues to outline the steps for assigning a waveform to a 

channel. 

 

Step Action 

8 The Card Settings section will differ depending on whether the 

user is defining an arbitrary or digital channel. 
 

Channel Type Settings 

Arbitrary In the Waveform field, select the 

desired waveform number from the 

list. 

Note: The numbers in the list 

correspond to the numbers listed in 

the Waveform Definition field on the 

left-hand side of the window. 

If the Input setting is set to RPM, the 

Cycles/Rev must be set correctly to 

complete the required calculations. In 

the Cycles/Rev field, type the number 

of cycles per revolution for the 

waveform data pattern. 

Note: Two revolutions are typically 

used to make a complete cycle of data. 

The Offset field allows arbitrary 

channels that sync with the master to 

shift the waveform by a number of 

data points. If an offset is required, 

type the amount to offset in this field. 

 
 

Continued on next page 
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Assigning a Gen1 Waveform, Continued 

 
Figure 56: 

WaveMaker 

Management 

LUIS Gen1 

Window  

This is an example of the WaveMaker Management window when defining 

an arbitrary channel for LUIS Gen1. 

 

 

Continued on next page 
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Assigning a Gen1 Waveform, Continued 

 
Assigning a 

Gen1 

Waveform, 

Continued 

This table continues to outline the steps for assigning a waveform to a 

channel. 

 

Step Action 

8 Continued 
 

Channel Type Settings 

Digital or Digital Sim In the Output field, select the correct 

output type. 

If the number of teeth per revolution 

of the flywheel is necessary, enter this 

number in the Teeth/Rev field. 

If PWM operation is desired for the 

channel, enter its heart beat frequency 

in the PWM HB Freq field. If PWM 

operation is not desired, this value 

should be set to 0. 

 
 

9 When all the assignments have been made, click the <Save> 

button. 

Note: This button saves the changes to the waveforms, but the 

configuration needs to be saved to make the changes permanent 

in the configuration file. 

Continued on next page 
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Assigning a Gen1 Waveform, Continued 

 
Figure 57: 

WaveMaker 

Management 

LUIS Gen1 

Window  

This is an example of the WaveMaker Management window when defining 

a digital channel for LUIS Gen1. 
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Exercise: Assigning a Gen1 Waveform 

 
Exercise: 

Defining and 

Assigning a 

Gen1 

Waveform 

The purpose of this exercise is to familiarize the user with using the 

WaveMaker Management window to define and assign waveforms. 

 

Step Action 

1 On the Home tab, click the Waveforms/Channels icon. 

Result: The WaveMaker Management window opens. 

2 Click the LUIS Gen1 tab at the top of the window. 

Result: The interface for assigning the Gen1 waveforms resident 

in the firmware displays, as shown in  Figure 58. 

3 On the right-hand side of the WaveMaker Management 

window, in the Channel Definition section, from the Server 

dropdown list, select PeakAdapter_#1. 

Result: The first channel is highlighted, and its information 

displays in the fields. 

4 Select Channel#1 in the channels list. In the Input field, select 

RPM. 

5 In the Card Type section, select the Arbitrary option. 

7 In the Arbitrary Card Settings section, in the Waveform field, 

select 2 from the dropdown list.  

Note: This sets the waveform to be 24+1/24+1 VR as indicated in 

the Waveform Definition field on the left-hand side of the 

window. 

8 In the Cycles/Rev field, type 2. 

9 In the Offset field, type 0. 

10 Click the <Save> button. 

Result: The waveform information is saved. 

11 Close the WaveMaker Management window and save the 

configuration. 

Continued on next page 
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Exercise: Assigning a Gen1 Waveform, Continued 

 
Figure 58: 

Assigning a 

Waveform 

This image is an example of assigning a waveform. 
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Chapter 5 – J1939 Sensors 

Overview 

 
Introduction Luis Gen2 provides the ability to receive J1939 messages through either the 

CAN servers or the Peak Adapter servers. The Main Module is used to 

broadcast J1939 messages. Messages and parameters are defined through the 

J1939 Datalink Sensor Simulation Management window. 

 
In This 

Chapter 
This table outlines the topics covered in this chapter. 

 

Topic See Page 

Setting up J1939 Messages 110 

Setting up J1939 Parameters 120 

Assigning a J1939 Parameter to Gauges 124 
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Section 1 – Setting up J1939 Messages 

Overview 

 
Introduction User can define J1939 messages that can transmit data through the Main 

Module or receive data through the Peak Adapter or CAN servers. 

 
In This Section This table outlines the topics covered in this section. 

 

Topic See Page 

Setting up J1939 Messages to Transmit 111 

Setting up J1939 Messages to Receive 116 

Importing J1939 Messages 118 
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Notes 
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Setting Up J1939 Messages to Transmit 

 
Setting Up 

J1939 Messages 

to Transmit 

This table outlines the steps for setting up J1939 messages to transmit through 

the CAN servers. 

 

Step Action 

1 With the appropriate configuration file open, from the Home tab, 

click the SAE J1939 Sensors icon. 

Result: The J1939 Datalink Sensor Simulation Management 

window displays, as shown in Figure 59. 

2 On the left-hand side of the window click the <Add New> 

button. 

Result: The New Message Creation dialog box displays. 

3 In the field, type the unique name of the J1939 message and click 

<OK>. 

Result: The name displays in the Name field as well as in the 

message list below. Defaults are loaded into the other fields. 

4 In the Desc field, type a description of the message. 

5 In the ID field, type the message ID. The message ID is the 

Parameter Group Number along with its Priority Bits and 

Source/Destination address. 

Note: Decimal values are valid. As the ID is typed, the Hex name 

displays. 

6 In the Rate field, select the appropriate rate, in milliseconds, from 

the dropdown list.  

Note: This is the rate the message is transmitting on the CAN bus. 

7 In the Length field, select the number of bytes that make up the 

data load for the message from the dropdown list. 

Continued on next page 
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Setting Up J1939 Messages to Transmit to Transmit, Continued 

 
Figure 59: 

J1939 Datalink 

Sensor 

Simulation 

Management 

Window 

This is an example of the J1939 Datalink Sensor Simulation Management 

window. 

 

 

 

Continued on next page 
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Setting Up J1939 Messages to Transmit to Transmit, Continued 

 
Setting Up 

J1939 Messages 

to Transmit, 
Continued 

This table continues to outline the steps for setting up J1939 messages to 

transmit through the CAN servers. 

 

Step Action 

8 Ensure that the Transmit option is selected. 

9 Click the <Baud> button. 

Result: The Configure the Baud Rate for CAN Bus dialog box 

displays, as shown in Figure 61. 

10 From the CAN Bus Plugin field, select the appropriate plugin. 

11 From the Baud Rate dropdown list, select the desired baud rate 

for the data transmission. 

12 When the rate has been set up, click the <Save> button. 

Result: The changes are saved and the dialog box closes. 

13 When the message has been defined, click the <Save> button. 

Result: The message definition is saved, but the configuration 

needs to be saved to make the changes permanent in the 

configuration file. 

Continued on next page 
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Setting Up J1939 Messages to Transmit to Transmit, Continued 

 
Figure 60: 

J1939 Datalink 

Sensor 

Simulation 

Management 

Window 

This is an example of the J1939 Datalink Sensor Simulation Management 

window. 

 

 

 

 
Figure 61: 

Configure the 

Baud Rate for 

Can Bus Dialog 

Box 

This is an example of the Configure the Baud Rate for Can Bus dialog box. 
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Setting Up J1939 Messages to Receive 

 
Setting Up 

J1939 Messages 

to Receive 

This table outlines the steps for setting up J1939 messages to receive through 

the Peak Adapter servers. 

 

Step Action 

1 With the appropriate configuration file open, from the Home tab, 

click the SAE J1939 Sensors icon. 

Result: The J1939 Datalink Sensor Simulation Management 

window displays, as shown in Figure 62. 

2 On the left-hand side of the window click the <Add New> 

button. 

Result: The New Message Creation dialog box displays, as 

shown in Figure 63. 

3 In the field, type the unique name of the J1939 message and click 

<OK>. 

Result: The name displays in the Name field as well as in the 

message list below. Defaults are loaded into the other fields. 

4 In the Desc field, type a description of the message. 

5 In the ID field, type the message ID. The message ID is the 

Parameter Group Number along with its Priority Bits and 

Source/Destination address. 

Note: Decimal values are valid. As the ID is typed, the Hex name 

displays. 

6 The Rate and Length fields are not necessary when setting up 

J1939 messages to receive. 

7 Ensure that the Receive via Peak Adapter option is selected. 

8 When the message has been defined, click the <Save> button. 

Result: The message definition is saved, but the configuration 

needs to be saved to make the changes permanent in the 

configuration file. 

Continued on next page 
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Setting Up J1939 Messages to Receive to Receive, Continued 

 
Figure 62: 

J1939 Datalink 

Sensor 

Simulation 

Management 

Window 

This is an example of the J1939 Datalink Sensor Simulation Management 

window. 

 

 

 

 
Figure 63: 

New Message 

Creation Dialog 

Box 

This image is an example of the New Message Creation dialog box. 
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Importing J1939 Messages 

 
Introduction J1939 Messages and their parameters defined in other configuration files can 

be imported in to the current configuration. 

 
Importing 

J1939 

Definitions 

This table outlines the steps for importing J1939 messages and parameters. 

 

Step Action 

1 With the appropriate configuration file open, from the Home tab, 

click the SAE J1939 Sensors icon. 

Result: The J1939 Datalink Sensor Simulation Management 

window displays, as shown in Figure 64. 

2 Click the <Import> button. 

Result: The Import Message dialog box displays. 

3 Browse for and find the configuration from which the J1939 

Messages should be imported then click <Open>. 

Result: The Select Items dialog box displays, as shown in Figure 

65, with the message definitions displayed. 

4 Select each of the messages to import and click <Import>. 

Note: The messages and their parameters are imported. If 

attempting to import a message with a duplicate name, LUIS will 

prompt whether or not to continue. 

5 Once the messages have been imported, click the <Save> button 

on the far right-hand side of the window to save the changes. 

Note: Save the configuration to make the changes permanent to 

the configuration file. 

Continued on next page 
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Importing J1939 MessagesImporting J1939 Messages, 
Continued 

 
Figure 64: 

J1939 Datalink 

Sensor 

Simulation 

Management 

Window 

This is an example of the J1939 Datalink Sensor Simulation Management 

window. 

 

 

 
Figure 65: 

Select Items 

Dialog Box 

This is an example of the Select Items dialog box. 
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Setting Up J1939 Parameters  

Setting Up J1939 Parameters 

 
Introduction Once a J1939 message has been set up, the user can define the parameters 

within that message. This is accomplished through the J1939 Datalink 

Sensor Simulation Management window.. 

 
Setting Up 

J1939 Message 

Parameters 

This table outlines the steps for setting up J1939 message parameters. 

 

Step Action 

1 With the appropriate configuration file open, from the Home tab, 

click the SAE J1939 Sensors icon. 

Result: The J1939 Datalink Sensor Simulation Management 

window displays, as shown in Figure 66. 

2 Verify the correct message definition has been set up. If it has 

not, set it up according to the steps in the previous sections of this 

chapter. 

3 On the Message Definition side of the window, select the desired 

J1939 Message. 

4 On the Message Parameter Definition side of the window, in 

the Name field, type a name for the parameter. 

Note: Parameter names must be unique. 

5 In the Start Bit field, select the start bit for the parameter. 

Note: The start bit is the first bit in the data load for the message 

where this parameter data starts. 

6 In the Length field, select the number of bits that make up the 

parameter. 

7 In the Resolution field, enter the value per bit in engineering 

units. 

Note: This value is used to convert the engineering units on a 

gauge to the actual transmitted data. 

Continued on next page 
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Setting Up J1939 Parameters, Continued 

 
Figure 66: 

J1939 Datalink 

Sensor 

Simulation 

Management 

Window 

This is an example of the J1939 Datalink Sensor Simulation Management 

window. 

 

 

Continued on next page 
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Setting Up J1939 Parameters, Continued 

 
Setting Up 

J1939 Message 

Parameters, 

Continued 

This table continues to outline the steps for setting up J1939 message 

parameters. 

 

Step Action 

8 In the Offset field, that the value of the data is offset. 

Note: This value is used to convert the engineering units on a 

gauge to the actual transmitted data. 

9 Once the parameter has been defined, click the <Add New> 

button. 

Result: The parameter is saved to the message and displays in the 

field below the parameter definition fields. 

10 To save the changes to the configuration, click the <Save> button 

on the far right-hand side of the window. 

Note: Save the configuration to make the changes permanent to 

the configuration file. 

Continued on next page 
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Setting Up J1939 Parameters, Continued 

 
Figure 67: 

J1939 Datalink 

Sensor 

Simulation 

Management 

Window 

This is an example of the J1939 Datalink Sensor Simulation Management 

window. 
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Section 3 – Assigning J1939 Parameters to Gauges 

Assigning J1939 Parameters to Gauges 

 
Introduction Once J1939 messages and parameters have been defined, the parameters can 

be assigned to gauges within the LUIS Gen2 workspace. 

 
Assigning a 

J1939 

Parameter to a 

Gauge 

This table outlines the steps for assigning a J1939 parameter to a gauge. 

 

Step Action 

1 Add a gauge to the appropriate tile within the configuration. 

2 Right-Click the control and select the Properties option from the 

menu. 

Result: The Toolbox dialog box displays, as shown in Figure 68. 

3 In the Component Options section, use Enable option to 

determine if the value of the control should be enabled, True, or 

not disabled, False. 

4 In the Component Options section, use the Gauge Type option 

to set if the gauge is Round or Slider. 

5 In the Hardware section, click the <…> button next to the 

Hardware Setup option. 

Result: The Hardware I/O Selection dialog box displays, as 

shown in Figure 69. 

6 In the Hardware Unit field, select either the 

MainModuleJ1939PortAPlugin or the PeakAdapterPlugin option. 

Result: The channels available in that module display in the 

Channel field. 

7 In the Channel field, select the appropriate channel. 

8 Click <OK> to close the dialog box. 

Result: The dialog box closes and the Channel and Type under 

Hardware Setup are filled in with the selection. 

Continued on next page 
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Assigning J1939 Parameters to Gauges, Continued 

 
Figure 68: 

Toolbox Dialog 

Box 

This is an example of the Toolbox dialog box. 

 

 

 
Figure 69: 

The Hardware 

I/O Selection 

Dialog Box 

This is an example of the Hardware I/O Selection dialog box. 

 

 

Continued on next page 



Page 126 

 

Assigning J1939 Parameters to Gauges, Continued 

 
Assigning a 

J1939 

Parameter to a 

Gauge, 

Continued 

This table continues to outline the steps for assigning a J1939 parameter to a 

gauge. 

 

Step Action 

9 In the Interpolation Table section, use the down arrow next to 

the Table Name option to select the appropriate interpolation 

table. 

10 In the Scale section, the scale for the control can be set including 

the Minimum and Maximum values as well as the Multiplier and 

Scale Resolution. 

11 In the Server section, use the down arrow next to the Name 

option to select the appropriate server. 

12 In the Text section, the TextLine1 and TextLine2 options are 

used to define the label that displays at the top of the control. 

13 The Value Definition section can be used to set the Default 

Value for the control. 

14 The rest of the options on the Properties dialog box are used to 

control the look of the control. These can be set as desired by the 

user. 

Note: More information about Interlock Setup can be found in the 

following chapter. 

Continued on next page 
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Assigning J1939 Parameters to Gauges, Continued 

 
Figure 70: 

Toolbox Dialog 

Box 

This is an example of the Toolbox dialog box. 
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Chapter 6 – Servers 

Overview 

 
Introduction The LUIS Gen2 has the ability to run multiple servers which connect to a 

separate USB interface. Each server can have multiple clients so that when 

data is sent to hardware devices, the data is reflected to any client connected. 

 

This diagram illustrates the hardware/software architecture. 

 

 
 

 In this architecture, the Client DLL performs all transactions, callbacks from 

servers as well as loading configurations and pushing waveform data to 

Wavemaker units. 

Continued on next page 
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Overview, Continued 

 
Interface Types There are three types of interfaces for servers. This table describes each type. 

 

Interface Type Description 

Pipe An internal Windows connection in the PC 

TCP Network interface connection utilizing 

Transmission Control Protocol 

HTTP Network interface connection utilizing 

HyperText Transport Protocol 

 

 

 
In This 

Chapter 
This table outlines the topics covered in this chapter. 

 

Topic See Page 

Setting Up Servers 104 

Deleting Servers 134 
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Notes 
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Section 1 – Setting Up Servers 

Setting Up Servers 

 
Introduction Before a server can be used in the LUIS Gen2 software, the server and 

interface types must be set up. 

 
Setting Up 

Servers 
This table outlines the steps for setting up a server. 

 

Step Action 

1 On the Home tab, click the Server List icon. 

Result: The Server Management window, shown in Figure 71, 

displays and the current servers are listed in the Servers field on 

the left-hand side. 

2 Click the <Add New> button. 

Result: The New Server Creation dialog box displays, as shown 

in Figure 72. 

3 Type the name of the new server and click <OK>. 

Result: The new server is added to the Servers field on the left-

hand side of the window, the name of the new server displays in 

the Name field on the right-hand side of the window, and the 

default information is filled in. 

4 From the Server Type dropdown list, select the appropriate server 

type. 

5 From the Interface Type dropdown list, select the appropriate 

interface type. 

6 If the Interface Type is Pipe, then in the Pipename field type the 

correct pipename. 

7 In the Description field, type a brief description of the server, if 

desired. 

8 If the Server Type is Peak Adapter, then in the NetName field, 

type the name of the net to which the server should connect. 

8 The Status field indicates the status of the server. If the server is 

disconnected, attempt to connect to the server by clicking the 

<Connect> button. 

9 When the server is set up, click the <Save> button. 

10 Close the Server Management window and save the 

configuration file. 

Continued on next page 
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Setting Up Servers, Continued 

 
Figure 71: 

Server 

Management 

Window 

This is an example of the Server Management window. 

 

 

 
Figure 72: 

New Server 

Creation Dialog 

Box 

This image is an example of the New Server Creation dialog box. 
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Section 2 – Deleting Servers 

Deleting Servers 

 
Deleting a 

Server 
To delete a server, open the Server Management window by clicking the 

Server List icon on the Home tab. Select the server to delete from the 

Servers list on the left-hand side of the window and click the <Delete> 

button. A dialog box displays to confirm the removal of the server. Click 

<OK> to delete the server. To make the changes permanent in the 

configuration file, be sure to save the configuration. 

Continued on next page 
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Deleting Servers, Continued 

 
Figure 73: 

Server 

Management 

Window 

This is an example of the Server Management window. 
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Chapter 7 – Controls 

Overview 

 
Introduction There are four types of controls used within the LUIS Gen2 environment to 

interact with the hardware: Closed Loop Control, Digital Display, Gauge 

and Switch. In addition, there is the Panel control that provides the option of 

adding labels. How these controls are manipulated within the GUI is 

explained in Chapter 2 – Navigating the LUIS Gen2 GUI. This chapter 

provides additional information about setting up and using each control type 

to interact with the hardware. 

 
In This 

Chapter 
This table outlines the topics covered in this chapter. 

 

Topic See Page 

Closed Loop Control 138 

Digital Displays 143 

Gauges 148 

Indicators 152 

Switches 154 

Interlocking Controls 160 

Panels 163 
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Section 1 – Closed Loop Control 

Closed Loop Control 

 
Introduction The LUIS Gen2 can be set to run closed loop engine speed control. In this 

mode, the engine speed signal generated by the load box responds similarly to 

an actual engine. J1939 public broadcast must be running in the ECM to run 

in closed loop mode. 

 
Closed Loop 

Control Panel 
The Closed Loop Control Panel consists of five elements. Figure 74 and this 

table describe these elements. 

 

Element Description 

Percent Load Either the slider or the digital display can be  

used to set the percent load for the model. 

Gain Adjust Either the slider or the digital display can be 

used to set the gain adjust for the model. 

<Closed Loop> This button is used to set the loop to closed 

or open. The button reads the current status, 

so when the button says <ON> it indicates 

that closed loop mode is on. 

<Start> This button is used to start closed loop 

control. This control is only available when 

the Closed Loop mode is ON. 

<Reset> This button sets the model back to zero 

load/rpm. This control is only available 

when the Closed Loop mode is ON. 

Continued on next page 
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Closed Loop Control, Continued 

 
Figure 74: 

Closed Loop 

Panel 

This is an example of a Closed Loop Panel control. 

 

 

Continued on next page 
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Closed Loop Control, Continued 

 
Configuring the 

Closed Loop 

Control 

This table outlines the steps for configuration a Closed Loop Control. 

 

Step Action 

1 Add a Closed Loop Control, as shown in Figure 75, to a tile by 

dragging it from the Tools Tab. 

2 Right-Click the control and Select the Properties option from the 

menu. 

Result: The Toolbox dialog box displays, as shown in Figure 76. 

3 In the Hardware section, the ECM Source ID is the J1939 source 

address of the ECM that should be used for the control when 

running multiple ECMs. If only running one ECM, the source ID 

will be 0. 

4 In the Hardware section, click the <…> button next to the 

Hardware Setup option. 

Result: The Hardware I/O Selection dialog box displays. 

5 In the Hardware Unit field, select the Wavemaker. 

Result: The channels available in that module displays in the 

Channel field. 

6 In the Channel field, select the appropriate channel. 

Important Note: The Closed Loop Control must be set to the 

Engine Speed Channel in the WaveMaker. 

7 Click <OK> to closed the dialog box. 

Result: The dialog box closes and the Channel and Type under 

Hardware Setup are filled in with the selections. 

8 In the Interpolation Table section, use the down arrow next to 

the Table Name option to select the appropriate interpolation 

table. 

Important Note: The Interpolation Table must match the 

interpolation table used for the Engine Speed channel. 

9 In the Server section, use the down arrow next to the Name 

option to select the appropriate server. 

Note: Gen1 uses the Peak Adapter and Gen2 uses the Wavemaker 

server. 

Continued on next page 
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Closed Loop Control, Continued 

 
Figure 75: 

Closed Loop 

Panel Control 

This is an example of a Closed Loop Panel control. 

 

 

 
Figure 76: 

Closed Loop 

Control 

Properties 

This is an example of the Toolbox dialog box for a Closed Loop Control. 

 

 

Continued on next page 
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Closed Loop Control, Continued 

 
Configuring the 

Closed Loop 

Control, 

Continued 

This table continues to outline the steps for configuration a Closed Loop 

Control. 

 

Step Action 

10 The Value Definition section can be used to set the Gain Value 

and Percent Load Value. These values can also be set using the 

slider or the digital display on the panel. 

11 The rest of the options on the Toolbox dialog box are used to 

control the look of the control. These can be set as desired by the 

user. 

Continued on next page 
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Closed Loop Control, Continued 

 
Closed Loop 

Control 

Properties 

This is an example of the Toolbox dialog box for a Closed Loop Control. 
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Section 2 – Digital Displays 

Digital Displays 

 
Introduction The Digital Display control provides a simple digital display of engineering 

units, counts and/or millivolts for an assigned channel. 

 
Digital Display The Digital Display consists of four elements. The label is always present, 

but the Eng Units, Counts, and mVolts displays can be displayed or hidden. 

Figure 77 and this table describe these elements. 

 

Element Description 

Label Displays a user defined label for the control 

Eng Units Displays the engineering units 

Counts Displays the counts 

mVolts Displays the millivolts 

 
Configuring the 

Digital Display 

Control 

This table outlines the steps for configuring a Digital Display control. 

 

Step Action 

1 Add a Digital Display, shown in Figure 77, to a tile by dragging 

it from the Tools tab. 

2 Right-Click the control and Select the Properties option from the 

menu. 

Result: The Toolbox dialog box displays, as shown in Figure 78. 

3 Determine which of the elements to display on the control. To 

remove an element from the display, in the Appearance section 

of the Toolbox, delete the units for the appropriate element: Eng 

Units, Table Units, and/or Hardware Output Units. 

Result: When the units are deleted, the element is removed from 

the Digital Display. 

Continued on next page 
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Digital Displays, Continued 

 
Figure 77: 

Digital Display 
This is an example of a digital display control displaying all elements. 

 

 

 
Figure 78: 

Digital Display 

Properties 

This is an example of the Toolbox dialog box for a Digital Display control. 

 

 

 



Page 146 

 

Digital Displays, Continued 

 
Configuring the 

Digital Display 

Control, 

Control 

This table continues to outline the steps for configuring a Digital Display 

control. 

 

Step Action 

4 In the Hardware section, click the <…> button next to the 

Hardware Setup option. 

Result: The Hardware I/O Selection dialog box displays. 

5 In the Hardware Unit field, select the appropriate module. 

Result: The channels available in that module displays in the 

Channel field. 

6 In the Channel field, select the appropriate channel. 

7 Click <OK> to closed the dialog box. 

Result: The dialog box closes and the Channel and Type under 

Hardware Setup are filled in with the selection. 

8 In the Interpolation Table section, use the down arrow next to 

the Table Name option to select the appropriate interpolation 

table. 

9 In the Scale section, the scale for the control can be set including 

the Minimum and Maximum values as well as the Multiplier and 

Scale Resolution. 

10 In the Server section, use the down arrow next to the Name 

option to select the appropriate server. 

11 In the Text section, the TextLine1 option is used to define the 

label that displays at the top of the control. 

12 The Value Definition section can be used to set the Default 

Value for the control. 

13 The Interlock section is used to interlock the value of this control 

with a parent control. More information about using interlocks 

can be found on Page 160. 

14 The rest of the options on the Properties dialog box are used to 

control the look of the control. These can be set as desired by the 

user. 

Note: More information about Interlock Setup can be found later 

in this chapter. 

Continued on next page 
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Digital Displays, Continued 

 
Figure 79: 

Digital Display 

Properties 

This is an example of the Toolbox dialog box for a Digital Display control. 
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Section 3 – Gauges 

Gauges 

 

 
Introduction The Gauge control provides a round or slider gauge to display and interact 

with the value of the assigned channel. 

 
Gauges The Gauge control consists of three elements. This table and Figure 80 

describe the Gauge control. 

 

Element Description 

Label Displays a user defined label for the control 

Gauge Graphical display of the value of the control 

Digital Display Digital readout of the value of the control 

 
Configuring the 

Gauge Control 
This table outlines the steps for configuring a Digital Display control. 

 

Step Action 

1 Add a Gauge, shown in Figure 80, to a tile by dragging it from 

the Tools tab. 

2 Right-Click the control and Select the Properties option from the 

menu. 

Result: The Toolbox dialog box displays, as shown in Figure 81. 

3 In the Component Options section, use Enable option to 

determine if the value of the control should be enabled, True, or 

disabled, False. 

4 In the Component Options section, use the Gauge Type option 

to set if the gauge is Round or Slider. 

5 In the Hardware section, click the <…> button next to the 

Hardware Setup option. 

Result: The Hardware I/O Selection dialog box displays. 

6 In the Hardware Unit field, select the appropriate module. 

Result: The channels available in that module displays in the 

Channel field. 

7 In the Channel field, select the appropriate channel. 

Continued on next page 
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Gauges, Continued 

 
Figure 80: 

Gauges 
These images are examples of both the round and slider gauge controls. 

 

             

 
Figure 81: 

Gauge 

Properties 

This is an example of the ToolBox dialog box for configuring gauges. 

 

 

Continued on next page 
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Gauges, Continued 

 
Configuring the 

Gauge Control, 

Continued 

This table continues to outline the steps for configuring a Digital Display 

control. 

 

Step Action 

8 Click <OK> to close the dialog box. 

Result: The dialog box closes and the Channel and Type under 

Hardware Setup are filled in with the selection. 

9 In the Interpolation Table section, use the down arrow next to 

the Table Name option to select the appropriate interpolation 

table. 

10 In the Scale section, the scale for the control can be set including 

the Minimum and Maximum values as well as the Multiplier and 

Scale Resolution. 

11 In the Server section, use the down arrow next to the Name 

option to select the appropriate server. 

12 In the Text section, the TextLine1 and TextLine2 options are 

used to define the label that displays at the top of the control. 

13 The Value Definition section can be used to set the Default 

Value for the control. 

14 The Interlock section is used to interlock the value of this control 

with a parent control. More information about using interlocks 

can be found on Page 160. 

15 The rest of the options on the Properties dialog box are used to 

control the look of the control. These can be set as desired by the 

user. 

Continued on next page 
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Gauges, Continued 

 
Figure 82: 

Gauge 

Properties 

This is an example of the ToolBox dialog box for configuring gauges. 
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Section 4 – Indicators 

Indicators 

 
Introduction The Indicator control displays the status of a resistive load. The status is 

updated every 100 milliseconds. 

 
Indicators The Indicator control consists of two elements. Figure 83 and this table 

describe these elements. 

 

Element Description 

Label Displays a user defined label for the control 

Indicator Graphical indicator that is grey when OFF and the 

user defined color when ON. 

Note: The default indicator ON color is red. 

 
Configuring the 

Indicator 

Control 

This table outlines the steps for configuring an Indicator control. 

 

Step Action 

1 Add an Indicator, as shown in Figure 83, to a tile by dragging it 

from the Tools tab. 

2 Right-Click the control and Select the Properties option from the 

menu. 

Result: The Toolbox dialog box displays, as shown in Figure 84. 

3 In the Appearance section, set the Indicator Color to the desired 

color. 

4 In the Hardware section, click the <…> button next to the 

Hardware Setup option. 

Result: The Hardware I/O Selection dialog box displays. 

5 In the Hardware Unit field, select the Resistive Load option. 

Result: The channels available in that module displays in the 

Channel field. 

6 In the Channel field, select the appropriate channel. 

Continued on next page 
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Indicators, Continued 

 
Figure 83: 

Indicators 
This is an example of an Indicator control. 

 

 

 
Figure 84: 

Indicator 

Control 

Properties 

This is an example of the ToolBox dialog box for an Indicator control. 

 

 

Continued on next page 
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Indicators, Continued 

 
Configuring the 

Indicator 

Control, 

Continued 

This table continues to outline the steps for configuring an Indicator control. 

 

Step Action 

7 Click <OK> to close the dialog box. 

Result: The dialog box closes and the Channel and Type under 

Hardware Setup are filled in with the selection. 

8 In the Text section, the TextLine1 and TextLine2 options are 

used to define the label that displays at the top of the control. 

9 The Value Definition section can be used to set the Indicator 

Value for the control. 

10 The rest of the options on the Properties dialog box are used to 

control the look of the control. These can be set as desired by the 

user. 

Continued on next page 
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Indicators, Continued 

 
Figure 85: 

Indicator 

Control 

Properties 

This is an example of the ToolBox dialog box for an Indicator control. 
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Section 5 – Switches 

Switches 

 
Introduction The Switch control provides the ability to interact with On/Off or True/False 

values in the hardware. Switches can be set as a toggle where the value 

remains in the current state until the switch is tripped again or momentary 

which trips the switch and then immediately returns to the default state. 

 
Switches The Switch control consists of two elements.  Figure 86 and this table 

describe these elements.  

 

Element Description 

Label Displays a user defined label for the control 

Switch Graphical button that trips the switch 

 
Configuring the 

Switch Control 
This table outlines the steps for configuring a Switch control. 

 

Step Action 

1 Add a Switch, shown in Figure 86, to a tile by dragging it from 

the Tools tab. 

2 Right-Click the control and Select the Properties option from the 

menu. 

Result: The Toolbox dialog box displays, as shown in Figure 87. 

3 In the Component Options section, use the Enable option to 

determine if the value of the control should be enabled, True, or 

disabled, False. 

4 In the Switch Type field, select either Toggle or Momentary. 

5 In the SwitchClosedText field, type the word that should display 

when the switch is closed. 

6 In the SwitchOpenText field, type the word that should display 

when the switch is open. 

Continued on next page 
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Switches, Continued 

 
Figure 86: 

Switches 
This image is an example of a Switch control. 

 

 

 
Figure 87: 

Switch Control 

Properties 

This is an example of the ToolBox dialog box for a switch control. 

 

 

Continued on next page 
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Switches, Continued 

 
Configuring the 

Switch Control 
This table outlines the steps for configuring a Switch control. 

 

Step Action 

8 In the Hardware section, click the <…> button next to the 

Hardware Setup option. 

Result: The Hardware I/O Selection dialog box displays. 

9 In the Hardware Unit field, select the appropriate module. 

Result: The channels available in that module displays in the 

Channel field. 

10 In the Channel field, select the appropriate channel. 

11 Click <OK> to close the dialog box. 

Result: The dialog box closes and the Channel and Type under 

Hardware Setup are filled in with the selection. 

12 In the Interpolation Table section, use the down arrow next to 

the Table Name option to select the appropriate interpolation 

table. 

13 In the Scale section, the scale for the control can be set including 

the Multiplier and Scale Resolution. 

14 In the Server section, use the down arrow next to the Name 

option to select the appropriate server. 

15 In the Text section, the TextLine1 and TextLine2 options are 

used to define the label that displays at the top of the control. 

16 The Value Definition section can be used to set the Default 

Value for the control. 

17 The Interlock section is used to interlock the value of this control 

with a parent control. More information about using interlocks 

can be found on Page 160. 

18 The rest of the options on the Properties dialog box are used to 

control the look of the control. These can be set as desired by the 

user. 

Continued on next page 
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Switches, Continued 

 
Figure 88: 

Switch Control 

Properties 

This is an example of the ToolBox dialog box for a switch control. 
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Section 6 – Interlocking Controls 

Interlocking Controls 

 
Introduction LUIS Gen2 supports the option of interlocking controls causing the values of 

the interlocked control(s) to change with the parent control. It is important to 

note that interlocks are only one level deep. Multiple child interlocks ca not 

be nested. The interlocking options for the child controls are set up in the 

ToolBox dialog box for the controls. 

 
Interlocking 

Controls 
This table outlines the steps for setting up a child control to be interlocked 

with another control. 

 

Step Action 

1 Ensure that the parent control has been set up. 

2 Right-click the control that should be set up as the child. 

Result: The ToolBox dialog box displays. 

3 In the Interlock Setup section, click the <…> button. 

Result: The Interlock Options dialog box displays, as shown in 

Figure 89. 

4 In the Interlock section, set the interlock to be Non-Inverting or 

Inverting. When the interlock is set to inverting, the child control 

value changes in the inverse of the parent. 

5 In the Hardware Unit section, select the hardware unit of the 

parent control. 

Result: The Channel field populates with the available channels. 

6 In the Channel section, select the channel of the parent control. 

7 In the Interlock On Value section, select the appropriate value 

on which to interlock. 

8 When finished, click the <OK> button. 

Result: The dialog box closes and the Channel, 

InterlockOperation, InterlockValueName, and Type fields are 

filled in on the ToolBox dialog box. 

Continued on next page 
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Interlocking Controls, Continued 

 
Figure 89: 

Interlock 

Options Dialog 

Box 

This is an example of the Interlock Options dialog box. 

 

 

Continued on next page 
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Interlocking Controls, Continued 

 
Viewing 

Children 
The Interlock Dependencies dialog box allows the user to see all other 

controls interlocked to the selected control. This table outlines the steps for 

viewing the children of a selected control. 

 

Step Action 

1 Right-click the control. 

Result: The ToolBox dialog box displays. 

2 Next to the Interlock Dependencies field, click the <…> button. 

Result: The Interlock Dependencies dialog box displays, as 

shown in Figure 90. This dialog box lists each of the channels 

that are interlocked with the selected control. 

Continued on next page 
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Interlocking Controls, Continued 

 
Figure 90: 

Interlock 

Dependencies 

Dialog Box 

This is an example of the Interlock Dependencies dialog box. 
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Section 7 – Panels 

Panels 

 
Introduction The Panel control provides the ability to create text boxes for labels. 

 
Using the Panel 

Control 
This table outlines the steps for using the Panel control as a label. 

 

Step Action 

1 Add a Panel control to a window by dragging it from the Tools 

tab. 

2 Click in the default text. 

Result: The cursor changes to a text editing cursor. 

3 Type the desired label using CTRL+ENTER to move to a new line. 

4 To change the text color, size or alignment right-click the control 

and select the Properties option from the menu. 

Result: The ToolBox dialog box displays, as shown in Figure 91. 

5 Use the options in the Appearance section to make changes to 

the text. 

Continued on next page 
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Panels, Continued 

 
Figure 91: 

Panel 

Properties 

This is an example of the ToolBox dialog box for the Panel control. 
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Notes 
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Chapter 8 – Module Descriptions 

Overview 

 
Overview This chapter provides additional technical information about the LUIS Gen2 

module hardware. 

 
Introduction A standard LUIS Gen2 system configuration contains: 

 

 Main Module 

 Wavemaker Module 

 2 Analog Modules 

 Switch Module 

 Resistive Loads Module 

 Injector and Application Specific Loads Module 

 

In addition, the user can request additional modules of each type depending 

on what is needed for their application. New modules are constantly being 

developed along with the ability to create custom modules for specific 

applications. Check with the GarTech engineering staff for additional 

information. 

 
In This 

Chapter 
This table outlines the topic covered in this section. 

 

Topic See Page 

Main Module 168 

Wavemaker Module 171 

Analog Module 174 

Switch Module 176 

Resistive Loads Module 178 

 

  



Page 168 

 

Section 1 – Main Module 

Main Module 

 
Front Panel 

Description 
This table outlines the controls found on the front panel of the Main LUIS 

Gen2 module. 

 

 
 

Control Function 

Power LED Indicates the internal power supply is powered on and 

functioning normally. 

Status LED Indicates that the module has completed its power up 

sequence and is ready to accept commands from the PC. 

VBATT LED Indicates that a VBATT source is connected and the 

VBATT relay is turned on. 

Note: If the relay is on, but no VBATT source is 

connected, the LED will not turn on. 

VBATT Test 

Point 

Provides a method for measuring VBATT voltage. 

Note: The test point is current limited to 20mA. 

RELAY 1-4 

LEDs 

Indicates that a relay source is connected and is turned 

on. 

Note: If the relay is on, but no source is connected, the 

LED will not turn on. 

RELAY 1-4 Test 

Points 

Provides a method for measuring relay voltage. 

Note: The relay is current limited to 20mA. 

Continued on next page 



Page 169 

 

Main Module, Continued 

 
Back Panel 

Description 
This table outlines the controls found on the back panel of the Main LUIS 

Gen2 module. 

 

 
 

Control Function 

AC inlet Provides connection to AC power. 

VBATT IN Provides connection to VBATT source. 

Note: Acceptable VBATT source range is 0 – 32V, 30A. 

USB Inlet Provides connection to PC via standard USB cable. 

Power Out Provides 8 pin connection for the application harness. 

J1939 SENSOR 

SIMULATION 

Provides a J1939 port for sensor simulation broadcast 

and RS232 connection for serial port control using 

legacy DLB commands. 

LOADS 

MODULE 

Provides power and GarTech proprietary control bus 

connections to the injector loads module. 

 

Continued on next page 
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Main Module, Continued 

 
Main Module 

Pinout 
This diagram illustrates the pinout for the main module. 
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Section 2 – Wavemaker Module 

Wavemaker Module 

 
Introduction Each Wavemaker Module supports up to 8 arbitrary waveform outputs with 

an arbitrary waveform card required for each channel. The arbitrary 

waveform outputs may range +/-6v, 12 bit resolution and up to 32 k 

datapoints per channel. In addition, any channel may be synchronized with 

any other channel. 

 

Each Wavemaker Module includes 10 digital outputs. These outputs can be 

set for 0-5v or +/-5v square wave output, up to 1MHz. Any digital channel 

may be synchronized with any other digital or arbitrary channel. 

 
Panel 

Descriptions 
The front panel of the Wavemaker Module provides indicator LEDS as well 

as output test points. The rear panel provides the connection to the ECM. 

 

     
 

This table describes the controls found on the front panel. 

 

Control Function 

POWER LED Indicates that the internal power supply is powered on 

and functioning normally. 

STATUS LED Indicates that the module has completed its power up 

sequence and is ready to accept commands from the PC. 

Continued on next page 
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Wavemaker Module, Continued 

 
Panel 

Descriptions, 

Continued 

This table continues to describe the controls found on the front panel of the 

Wavemaker Module. 

 

Control Function 

Output Test 

Points 

Provides a method for measuring voltage for each of the 

outputs. 

ARBITRARY 

LEDs 

Indicates if a card is installed for each of the arbitrary 

channels. 

DIGITAL LEDs Indicates if a card is installed for each of the digital 

channels. 

Continued on next page 
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Wavemaker Module, Continued 

 
Wavemaker 

Module Pinout 
This diagram illustrates the pinout for the Wavemaker module. 
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Section 3 - Analog Module Description 

Analog Module Description 

 
Introduction The analog outputs are arranged in groups of 4, and each group requires a 

reference voltage input. The reference voltage range is 0=15v. All outputs are 

16 bit and are scaled from 0-Vref with a 20mA current limit per output. Up to 

4 Analog Modules are supported by the system. 

 
Panel 

Descriptions 
The front panel of the Analog Module provides indicates LEDS and test 

points, and the rear panel provides the connection to the ECM. 

 

     
 

This table describes the controls on the front panel. 

 

Control Function 

POWER LED Indicates that the internal power supply is powered on 

and functioning normally. 

STATUS LED Indicates that the module has completed its power up 

sequence and is ready to accept commands from the PC. 

Test Points Provides a method for measuring voltage for each of the 

outputs. 

Note: The test points are limited to 20mA output. 

Continued on next page 
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Analog Module Description, Continued 

 
Analog Module 

Pinout 
This diagram illustrates the pinout for the Analog module. 
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Section 4 – Switch Module Description 

Switch Module Description 

 
Introduction Switch contacts are rated for 1.5A. The internal switch relay commons are 

connected in groups of 5. If a jumper is inserted between pins 41 and 50 at the 

rear panel, the commons remain in the groups of 5. However, if no jumper is 

connected, all 8 group commons are in turn tied together making all switch 

commons equal. Up to 2 switch modules are supported by the system. 

 
Panel 

Descriptions 
The front panel of the Switch Module provides indicates LEDS and the rear 

panel provides the connection to the ECM. 

 

      
 

This table describes the controls found on the front panel. 

 

Control Function 

POWER LED Indicates that the internal power supply is powered on 

and functioning normally. 

STATUS LED Indicates that module has completed its power up 

sequence and is ready to accept commands from the PC. 

SWITCH 

STATUS LEDs 

Indicates the ON/OFF state of each switch. 

Continued on next page 
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Switch Module Description, Continued 

 
Switch Module 

Pinout 
This diagram illustrates the pinout for the Switch Module. 
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Section 5 – Resistive Loads Module Description 

Resistive Loads Module Description 

 
Introduction The Resistive Loads Module contains a total of twelve 1k ohm loads and 

twenty-four 100 ohm loads. Four of the 100 ohm loads are used to drive 30A 

automotive relays, and the relay contracts are available at the back panel of 

the connector. 

 
Panel 

Descriptions 
The front panel of the Resistive Loads Module provides indicator LEDS and 

the rear panel provides the relay contacts. 

 

          
 

This table describes the controls found on the front panel. 

 

Control Function 

POWER LED Indicates that the internal power supply is powered on 

and functioning normally. 

STATUS LED Indicates that the module has completed its power up 

sequence and is ready to accept commands from the PC. 

RELAY STAUS 

LEDs 

Indicates whether each load is being driven. 

Continued on next page 
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Resistive Loads Module Description, Continued 

 
Resistive Loads 

Pinout 
This diagram illustrates the pinouts for the Resistive Loads Module. 

 

 

 


